Bug 609523 - ldap doesn't start
ldap doesn't start
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openldap (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Jan Zeleny
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-30 09:44 EDT by Jaroslav Škarvada
Modified: 2010-07-15 17:01 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 02:45:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Škarvada 2010-06-30 09:44:58 EDT
Description of problem:
# /etc/init.d/slapd start
/var/lib/ldap/__db.003 is not owned by "ldap"              [WARNING]
/var/lib/ldap/__db.006 is not owned by "ldap"              [WARNING]
/var/lib/ldap/__db.004 is not owned by "ldap"              [WARNING]
/var/lib/ldap/__db.001 is not owned by "ldap"              [WARNING]
/var/lib/ldap/__db.005 is not owned by "ldap"              [WARNING]
/var/lib/ldap/__db.002 is not owned by "ldap"              [WARNING]
/var/lib/ldap/alock is not owned by "ldap"                 [WARNING]
ln: accessing `/var/run/openldap/slapd.pid': No such file or directory

# /etc/init.d/slapd status
slapd dead but subsys locked

# chown ldap /var/lib/ldap/__db.*
# chown ldap /var/lib/ldap/alock

# /etc/init.d/slapd stop
Stopping slapd:                                            [FAILED]

# /etc/init.d/slapd start
Starting slapd:                                            [  OK  ]

# /etc/init.d/slapd status
slapd (pid  2174) is running...

Version-Release number of selected component (if applicable):
openldap-servers-2.4.21-4.fc13

How reproducible:
Always

Steps to Reproduce:
1. Install openldap-servers.
2. /etc/init.d/slapd start
  
Actual results:
There are warnings and the ldap doesn't start.

Expected results:
No warnings and clean start of ldap.

Additional info:
Tested on two computers with clean install of F13 + latest updates.
Comment 1 Fedora Update System 2010-06-30 13:36:03 EDT
openldap-2.4.21-8.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/openldap-2.4.21-8.fc13
Comment 2 Jan Zeleny 2010-06-30 13:38:18 EDT
Please re-test with above update.
Comment 3 Jaroslav Škarvada 2010-07-01 03:31:25 EDT
Sorry, but the problem still persists. Probably it is because the /var/lib/ldap ownership is changed in "pre servers", but the /var/lib/ldap directory is created during install, thus it doesn't exist in "pre" phase. For upgrade it works, but for clean install it is not.
Comment 4 Jan Zeleny 2010-07-01 05:56:52 EDT
Sorry, my bad. I mistook the fix with the fix for something else. Another build will be available in a few minutes.
Comment 5 Fedora Update System 2010-07-01 06:06:27 EDT
openldap-2.4.21-9.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/openldap-2.4.21-9.fc13
Comment 6 Jaroslav Škarvada 2010-07-01 06:17:57 EDT
Now it works for me, thanks.
Comment 7 Jan Zeleny 2010-07-02 02:45:58 EDT
Perfect - the update is in testing for F13 and it is also available in rawhide. I'm closing the bug.
Comment 8 Fedora Update System 2010-07-14 18:54:56 EDT
openldap-2.4.21-8.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2010-07-15 17:01:27 EDT
openldap-2.4.21-9.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.