Bug 60953 - RFE: upgrade does not offer to keep GRUB password
Summary: RFE: upgrade does not offer to keep GRUB password
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-10 12:06 UTC by Alexandre Oliva
Modified: 2007-04-18 16:40 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-21 16:23:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alexandre Oliva 2002-03-10 12:06:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020204

Description of problem:
Choosing the Upgrade option in the installer and choosing GRUB as the boot
loader doesn't offer an option to keep the existing GRUB password unchanged.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Do a minimal install of beta2, with grub as the boot loader, with a password.
2.Decide to install more packages, so start over and choose upgrade
3.Choose GRUB as the boot loader again.
4.Get to the GRUB password screen (in text mode)
	

Actual Results:  There's no option to keep the existing password unchanged.

Expected Results:  I wish there were such an option.

Additional info:

I haven't verified whether the original password is retained if I choose `No
password'.  I hope not, because it would be misleading at best.

Comment 1 Jeremy Katz 2002-03-11 19:50:59 UTC
It's not... this is because we don't actually preserve the grub config on an
upgrade.  Which is somewhat broken, but the changes to not do this weren't going
to be ready for the accelerated Hampton schedule.  Ugh :(

I'll see what I can do on this later this week

Comment 2 Jeremy Katz 2002-03-13 05:36:44 UTC
I've changed the way bootloader configuration is handled on upgrades.  Testing
of this for the next beta would be much appreciated (basically, now you get a
choice of just updating your current config, doing nothing, or creating a new
config)

Comment 3 Josep L. Guallar-Esteve 2002-03-28 18:53:36 UTC
* test tree Skipkjack-re0320.0 i386  
* test case i386/English/Worlstation/CDROM/GUI plus   
i386/English/Upgrade existing system/CDROM/GUI   
* test case i386/English/Upgrade/CDROM/GUI/From 7.2   
  
- First instalation OK. Grub set up with password.  
 
- On the update from Skipjack to Skipjack, I selected to 
install further packages and the default bootloader option 
(Update existing installation). The update respected the Grub 
password.  
 
- On the update from 7.2 to Skipjack, update respected the Grub 
password.


Note You need to log in before you can comment on or make changes to this bug.