Bug 609532 - VM Universe jobs that fail to exe get put on Hold
VM Universe jobs that fail to exe get put on Hold
Status: CLOSED NOTABUG
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: condor (Show other bugs)
1.0
All Linux
low Severity medium
: 2.0
: ---
Assigned To: Timothy St. Clair
MRG Quality Engineering
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-30 10:16 EDT by Robert Rati
Modified: 2011-03-11 12:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-11 12:08:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Rati 2010-06-30 10:16:29 EDT
Description of problem:
VM Universe jobs that have problems executing get put on Hold with a HoldReason set.  A failure to run on one machine does not mean it would fail to execute on another VM capable execute node.  VM Universe jobs that fail to run should be placed back in Idle state rather than on Hold.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Timothy St. Clair 2011-02-17 16:15:04 EST
Are there any details on the HoldReason?
Comment 2 Robert Rati 2011-02-17 17:06:39 EST
I don't recall the HoldReason.  Likely a statement that the job could not run.
Comment 4 Timothy St. Clair 2011-03-11 12:08:50 EST
So in looking through the code, this is expected behavior if the job outright fails to execute with some error (usually due to some botched submission or configuration).

e.g.

Hold reason: Error from slot1@tstclair.redhat.com: VMGAHP_ERR_INTERNAL

Note You need to log in before you can comment on or make changes to this bug.