Bug 609548 - icebp (opcode 0xf1) no longer causing a SIGTRAP, breaks Wine
Summary: icebp (opcode 0xf1) no longer causing a SIGTRAP, breaks Wine
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 13
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Patch
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-30 15:00 UTC by Michael Hampton
Modified: 2010-07-08 18:23 UTC (History)
8 users (show)

Fixed In Version: kernel-2.6.33.6-147.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-08 18:23:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 16315 None None None Never

Description Michael Hampton 2010-06-30 15:00:45 UTC
Description of problem:
Several Windows applications under Wine are breaking, notably World of Warcraft, due to a kernel bug introduced in 2.6.33.

Version-Release number of selected component (if applicable):
2.6.33.5-124.fc13.i686
2.6.33.5-124.fc13.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora 13.
2. Install World of Warcraft.
3. Login to World of Warcraft.
  
Actual results:
Wine crash with null pointer dereference or other errors, as reported at http://bugs.winehq.org/show_bug.cgi?id=23323

Expected results:
Application should run normally

Additional info:
This has been fixed upstream and I would like to see the fix backported into Fedora's kernel, because it likely affects a number of smaller, less well known Windows apps running in Wine, for which the users may not realize a kernel bug is the cause.

For more information see upstream https://bugzilla.kernel.org/show_bug.cgi?id=16315

Comment 2 Chuck Ebbert 2010-07-06 16:06:59 UTC
Fixed in 2.6.33.6-146

Comment 3 Fedora Update System 2010-07-07 07:20:33 UTC
kernel-2.6.33.6-147.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/kernel-2.6.33.6-147.fc13

Comment 4 Fedora Update System 2010-07-07 17:43:17 UTC
kernel-2.6.33.6-147.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/kernel-2.6.33.6-147.fc13

Comment 5 Fedora Update System 2010-07-08 18:22:34 UTC
kernel-2.6.33.6-147.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.