Bug 609562 - nautilus gets stuck in a loop on startup
nautilus gets stuck in a loop on startup
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: nautilus-python (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Patrick Dignan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-30 11:47 EDT by Dave Jones
Modified: 2015-01-04 17:31 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-14 15:50:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2010-06-30 11:47:04 EDT
when I log in, cpu goes to 100% use, and the desktop never loads.
stracing nautilus shows this happening over and over..

stat("/usr/lib/python2.6/site-packages/gi", 0x7fff070ad7c0) = -1 ENOENT (No such file or directory)
open("/usr/lib/python2.6/site-packages/gi.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/python2.6/site-packages/gimodule.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/python2.6/site-packages/gi.py", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/python2.6/site-packages/gi.pyc", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib64/python2.6/gi", 0x7fff070ad6f0) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.6/gi.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.6/gimodule.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.6/gi.py", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.6/gi.pyc", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib64/python2.6/plat-linux2/gi", 0x7fff070ad6f0) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.6/plat-linux2/gi.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.6/plat-linux2/gimodule.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.6/plat-linux2/gi.py", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.6/plat-linux2/gi.pyc", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib64/python2.6/lib-dynload/gi", 0x7fff070ad6f0) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.6/lib-dynload/gi.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.6/lib-dynload/gimodule.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.6/lib-dynload/gi.py", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.6/lib-dynload/gi.pyc", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib64/python2.6/site-packages/gi", 0x7fff070ad6f0) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.6/site-packages/gi.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.6/site-packages/gimodule.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.6/site-packages/gi.py", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.6/site-packages/gi.pyc", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib64/python2.6/site-packages/PIL/gi", 0x7fff070ad6f0) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.6/site-packages/PIL/gi.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.6/site-packages/PIL/gimodule.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.6/site-packages/PIL/gi.py", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.6/site-packages/PIL/gi.pyc", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib64/python2.6/site-packages/gst-0.10/gi", 0x7fff070ad6f0) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.6/site-packages/gst-0.10/gi.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.6/site-packages/gst-0.10/gimodule.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.6/site-packages/gst-0.10/gi.py", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.6/site-packages/gst-0.10/gi.pyc", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib64/python2.6/site-packages/gtk-2.0/gi", 0x7fff070ad6f0) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.6/site-packages/gtk-2.0/gi.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.6/site-packages/gtk-2.0/gimodule.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.6/site-packages/gtk-2.0/gi.py", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.6/site-packages/gtk-2.0/gi.pyc", O_RDONLY) = -1 ENOENT (No such file or directory)
stat("/usr/lib64/python2.6/site-packages/webkit-1.0/gi", 0x7fff070ad6f0) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.6/site-packages/webkit-1.0/gi.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.6/site-packages/webkit-1.0/gimodule.so", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.6/site-packages/webkit-1.0/gi.py", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib64/python2.6/site-packages/webkit-1.0/gi.pyc", O_RDONLY) = -1 ENOENT (No such file or directory)
Comment 1 Dave Jones 2010-07-12 11:53:31 EDT
this is still happening. I have to kill -STOP nautilus when I log in, otherwise my laptop will catch fire.

.xsession-errors shows ..

Gtk-Message: Failed to load module "atk-bridge": libatk-bridge.so: cannot open shared object file: No such file or directory
Gtk-Message: Failed to load module "gail-gnome": libgail-gnome.so: cannot open shared object file: No such file or directory
** Message: pygobject_register_sinkfunc is deprecated (GtkWindow)
** Message: pygobject_register_sinkfunc is deprecated (GtkInvisible)
** Message: pygobject_register_sinkfunc is deprecated (GtkObject)
/usr/lib64/python2.6/site-packages/gtk-2.0/gtk/__init__.py:40: Warning: cannot register existing type `GtkObject'
  from gtk import _gtk
/usr/lib64/python2.6/site-packages/gtk-2.0/gtk/__init__.py:40: Warning: g_type_register_static: assertion `parent_type > 0' failed
  from gtk import _gtk
/usr/lib64/python2.6/site-packages/gtk-2.0/gtk/__init__.py:40: Warning: g_once_init_leave: assertion `initialization_value != 0' failed
  from gtk import _gtk
/usr/lib64/python2.6/site-packages/gtk-2.0/gtk/__init__.py:40: Warning: g_type_get_qdata: assertion `node != NULL' failed
  from gtk import _gtk
Comment 2 Dave Jones 2010-07-16 17:10:18 EDT
removing nautilus-python made this problem go away.
Comment 3 Mads Kiilerich 2010-07-25 08:19:58 EDT
Dave, what version of nautilus-python was that? The one from f13 (because it haven't been rebuild for f14)?
Comment 4 Patrick Dignan 2010-07-25 12:20:39 EDT
Hi, I've rebuilt the package for rawhide.  I'm going to be looking into the new release as well.

Does this problem still occur with the rebuilt package?
Comment 5 Dave Jones 2010-07-29 21:02:58 EDT
looks good with the 0.6.1-1.fc13 build.
Comment 6 Bug Zapper 2010-07-30 08:19:31 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Dave Jones 2010-08-13 10:53:14 EDT
I did a fresh install on a box yesterday, which pulled in nautilus-python-0.7.0-2.fc14.x86_64 when I installed postr.  When I rebooted this morning, this problem returned.

Note You need to log in before you can comment on or make changes to this bug.