This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 609633 - Rebase to latest RADIUS release
Rebase to latest RADIUS release
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: freeradius2 (Show other bugs)
5.5
All Linux
high Severity medium
: rc
: ---
Assigned To: John Dennis
Aleš Mareček
: Rebase
Depends On: 602567
Blocks: 644100 736878 758797
  Show dependency treegraph
 
Reported: 2010-06-30 13:37 EDT by Dmitri Pal
Modified: 2012-11-20 09:41 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of: 602567
: 644100 736878 (view as bug list)
Environment:
Last Closed: 2012-02-21 00:36:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Legacy) 46793 None None None Never

  None (edit)
Description Dmitri Pal 2010-06-30 13:37:11 EDT
I don't have the exact same problem, but do have a serious problem with Freeradius2, which too is fixed in 2.1.8. The current release of RedHat freeradius needs to be upgraded.

Problem and response from Freeradius developer:

==========================
  > We are running Freeradius 2.1.7 (on CentOS 5 - freeradius2-2.1.7-7.el5),
  > and are seeing many of these messages in our log files:
  > 
  >   Fri Jun 11 11:44:19 2010 : Error: Failed binding to proxy address *
  >   port 1815: Address already in use
  > 
  > The server is already running and so would already be bound to the port,
  > so why is it trying to bind to it again? These seem to occur initially
  > in ones or twos, but eventually the server stops responding completely
  > to requests. At that point we have to restart the radiusd process.
  > 
  > Is this known about and maybe fixed in 2.1.9? Or is something else going
  > on here?

  Changelog from 2.1.8:

        * Proxying large numbers of packets no longer gives error
          "unable to open proxy socket".
==========================

This is from the freeradius user s mailing list, Subject line "FR 2.1.7: Error: Failed binding to proxy address". This problem is seriously affecting our RADIUS service, so needs to be sorted out soon.



John.
Comment 1 Dmitri Pal 2010-06-30 13:48:07 EDT
We are not planning to rebase the freeradius2 package in 5.6 release.

If you need this specific fix please log a case with customer support and we will try to extract and back port the solution for it. In this case it will be delivered as an errata.
Comment 4 John Horne 2010-07-01 06:43:04 EDT
I submitted this problem. However, for us it was a show stopper. We upgraded from an old 2.0.5 package to 2.1.7. This caused us problems, which we were told were fixed in 2.1.8 (hence the original report #602567). Since we had to build the package from source we used the latest code version (2.1.9). This fixed one problem, but we still had another problem which we were told was fixed in the development version 2.1.10.

So, to get a working service we are currently using 2.1.10 built from the git source. Unless you are going to repackage freeradius2 with 2.1.10 (when it is released), then we have no option but to use a locally built package. This is not a problem for us. I would suggest closing this call.




John.
Comment 22 errata-xmlrpc 2012-02-21 00:36:09 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0196.html

Note You need to log in before you can comment on or make changes to this bug.