Bug 609634 - [Cisco 5.6 FEAT] Update enic driver to version 1.4.1.1
[Cisco 5.6 FEAT] Update enic driver to version 1.4.1.1
Status: CLOSED DUPLICATE of bug 568111
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.6
x86_64 Linux
low Severity high
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-30 13:39 EDT by Vasanthy Kolluri
Modified: 2010-06-30 16:52 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-30 16:52:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vasanthy Kolluri 2010-06-30 13:39:56 EDT
1.  Feature Overview:
     a. Name of feature:
     Update enic driver to the latest version enic-1.4.1.1

     b. Feature Description
     Bug fixes and updates to enic driver. We recommend that our partners always update to the latest enic driver version. 


2.  Feature Details:
     a. Architectures:
         32-bit x86
         64-bit Intel EM64T/AMD64

                :
     b. Red Hat Bugzilla Dependencies:

     c. Drivers or hardware dependencies:

     d. Upstream acceptance information:
        This driver has already been accepted by the netdev maintainers and applied to net-next-2.6 kernel.
        
        Update Summary:
        
        01/10 - Feature Add: Replace LRO with GRO
        02/10 - Bug Fix: Change hardware ingress vlan rewrite mode
        03/10 - Use a lighter reset operation for enic devices
        04/10 - Clean up: Add wrapper routines for firmware devcmd calls
        05/10 - Use (netdev|dev|pr)_<level> macro helpers for logging
        06/10 - Add new firmware devcmds
        07/10 - Use receive queue buffer blocks of 32/64 entries
        08/10 - Feature Add: Add loopback capability to enic devices
        09/10 - Bug Fix: Handle surprise hardware removals
        10/10 - Clean ups

        Signed-off-by: Scott Feldman <scofeldm@cisco.com>
        Signed-off-by: Vasanthy Kolluri <vkolluri@cisco.com>
        Signed-off-by: Roopa Prabhu <roprabhu@cisco.com>

        git tree log:

        $ git log --pretty=oneline drivers/net/enic
        29046f9b1e36f6e3332ce2d8e366005fd177b37a enic: Clean ups
        506e1198413d28446f9a98792b2b38b6bf5f8295 enic: Bug Fix: Handle surprise hardware removals
        1825aca667196f75b193e2d509ea96ffdc8db0ca enic: Feature Add: Add loopback capability to enic devices
        b5bab85c15ed3d1ae7f917a7c077086ac6c04572 enic: Use receive queue buffer blocks of 32/64 entries
        70feadf36df94dc0dc2f32fec4c131ecd75344f2 enic: Add new firmware devcmds
        a7a79debcca02fbf908c0abed8d8fb25d0e51b48 enic: Use (netdev|dev|pr)_<level> macro helpers for logging
        383ab92f11dd78d365ed05cf4d83ca2acc069a1f enic: Clean up: Add wrapper routines for firmware devcmd calls
        99ef563901a18d44a6c2eadd2b958e2e83aeca51 enic: Use a lighter reset operation for enic devices
        f8cac14acff870203ea7f61f1a92c5486d1774fa enic: Bug Fix: Change hardware ingress vlan rewrite mode
        88132f55d74fdd97a7d459007b2bbb59e850f8c0 enic: Feature Add: Replace LRO with GRO

     e. External links:
        Patch Series: http://marc.info/?l=linux-netdev&m=127741255511742&w=2
       
        Patches:
        01/10) http://marc.info/?l=linux-netdev&m=127741257211772&w=2
        02/10) http://marc.info/?l=linux-netdev&m=127741259711821&w=2
        03/10) http://marc.info/?l=linux-netdev&m=127741260611852&w=2
        04/10) http://marc.info/?l=linux-netdev&m=127741262111856&w=2
        05/10) http://marc.info/?l=linux-netdev&m=127741266111913&w=2
        06/10) http://marc.info/?l=linux-netdev&m=127741270811978&w=2
        07/10) http://marc.info/?l=linux-netdev&m=127741271611990&w=2
        08/10) http://marc.info/?l=linux-netdev&m=127741272512023&w=2
        09/10) http://marc.info/?l=linux-netdev&m=127741273412033&w=2
        10/10) http://marc.info/?l=linux-netdev&m=127741275112063&w=2
         
        
     f. Severity (U,H,M,L): 
         High (required for Hardware Enablement)


     g. Target Release Date:


3. Business Justification:
     a. Why is this feature needed?
     For bug fixes and enhancements to Cisco VIC Ethernet NIC driver
     b. What hardware does this enable?
     Cisco's VIC Ethernet NIC included with Cisco's UCS blade server product
     c. Forecast, impact on revenue?

     d. Any configuration info?
     e. Are there other dependencies (drivers).

4. Primary contact at Red Hat, email, phone (chat)
    Andrius T. Benokraitis
    andriusb@redhat.com

5. Primary contact at Partner, email, phone (chat)
   Vasanthy Kolluri
   vkolluri@cisco.com
   408-387-6014
Comment 1 Andrius Benokraitis 2010-06-30 16:52:58 EDT
Closing this as a dupe of the original 1.3.1.1 request, I don't think work as begun so let's just use that one bugzilla for this.

*** This bug has been marked as a duplicate of bug 568111 ***

Note You need to log in before you can comment on or make changes to this bug.