This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 60964 - Hampton B2 - upgrade misses installed LPRng package
Hampton B2 - upgrade misses installed LPRng package
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-10 15:21 EST by R P Herrold
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-11 15:47:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rpm -qa listing -- note dupe entry (8.77 KB, text/plain)
2002-03-10 15:22 EST, R P Herrold
no flags Details

  None (edit)
Description R P Herrold 2002-03-10 15:21:32 EST
Hampton Beta 2

Upgrade

-- did not spot a prior version and remove it -- installed another over top ...

LPRng-3.8.5-2
LPRng-3.8.7-2

... possible RPM database error ?

----------------------------

Which MAY be causing this error:


Subject: lpd-B2

Stopping lpd: ^[[60G[^[[1;31mFAILED^[[0;39m]
Starting lpd: Traceback (most recent call last):
  File "/usr/sbin/printconf-backend", line 7, in ?
    import printconf_backend
  File "/usr/share/printconf/util/printconf_backend.py", line 29, in ?
    from printconf_conf import *
  File "/usr/share/printconf/util/printconf_conf.py", line 82, in ?
    from xml.utils import qp_xml
ImportError: No module named utils
No Printers Defined^[[60G[  ^[[1;32mOK^[[0;39m  ]

----------------------

I have a full rpm -qa | sort 

will attach in a moment
Comment 1 R P Herrold 2002-03-10 15:22:24 EST
Created attachment 48068 [details]
rpm -qa listing -- note dupe entry
Comment 2 Jeremy Katz 2002-03-11 15:00:36 EST
What were you upgrading from?  The only place I see a 3.8.5-2 is in the old
Hampton beta.  

Now then, where's my wet noodle? ;-)

If you look in your upgrade.log, though, you'll probably see that a %pre or
%post failed due to the changing environment that was going on.  There's a
reason we said beta 1 to beta 2 upgrades weren't supported.
Comment 3 R P Herrold 2002-03-11 15:47:07 EST
... I plead youthful enthusiasm, and long service. <grin>

RH 7.1 patched current -> Hampton B1 -> Hampton B2

But I filed against anaconda rather than LprNG -- it looks like an 
RPM transaction set generated by anaconda did not pick up and add the
remove of the prior version.  and that is a generic Upgrade failure, 
rather than H-B1 -> H-B2 related, is it not?

A LprNG filing _would_ have have earned the noodle. <smile>
Comment 4 Jeremy Katz 2002-03-11 19:52:02 EST
No, we always add packages with "u" to the transaction set which is upgrade. 
But if scriptlets fail, then you'll regularly get the double package install
phenomena.

And anaconda is especially where beta 1 -> beta 2 "upgrades" can't be supported :)

Note You need to log in before you can comment on or make changes to this bug.