Bug 60967 - Wrong file permissions in XFree86 4.1.0-15
Summary: Wrong file permissions in XFree86 4.1.0-15
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.2
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-10 21:03 UTC by Need Real Name
Modified: 2007-04-18 16:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-12 08:38:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-03-10 21:03:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
The misc font.dir file (and maybe others I haven't checked yet) supplied with
the XFree86 4.1.0-15 update for Red Hat 7.2 seems to have -rw-------
permissions. THIS IS A BAD THING as it may cause X to not start because it
cannot find the default fixed font.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Upgrade to new X package
2.check font.dir permissions in misc form dir
3. if not world readable, watch X fail to start
	

Actual Results:  X did not start

Expected Results:  X should have started

Additional info:

My system is using RH 7,2, whuch was upgraded from 7.1....6.2

Comment 1 Mike A. Harris 2002-03-12 08:38:17 UTC
fonts.dir files are not supplied.  They are created after installation.
I have fixed a perm problem with this by forcing mkfontdir to set the
permission explicitly to 644.

I'm not sure how it could possibly be getting perms wrong now.  I'll have to
investigate.

Comment 2 Mike A. Harris 2002-04-08 22:58:44 UTC
Definitely is fixed in current Rawhide release 4.2.0-6.60.  I don't recall
the exact release these fixes went into, but I believe the latter 4.1.0 series
has them as well.


Note You need to log in before you can comment on or make changes to this bug.