Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 609720 - Incorrect description of filesystem type used in nfs(5) man page
Incorrect description of filesystem type used in nfs(5) man page
Status: CLOSED DUPLICATE of bug 637198
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nfs-utils (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: J. Bruce Fields
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-30 17:54 EDT by Sachin Prabhu
Modified: 2011-01-19 14:15 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-19 14:15:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sachin Prabhu 2010-06-30 17:54:27 EDT
the nfs(5) man page states

--
       The fstype field contains either "nfs" (for version 2 or version 3  NFS
       mounts)  or  "nfs4"  (for NFS version 4 mounts).  The nfs and nfs4 file
       system types share similar mount options, which are described below.
--


This is incorrect. The fstype nfs can also denote NFS version 4 mounts. fstype nfsv4 is also provided for legacy reasons.
Comment 2 J. Bruce Fields 2010-11-22 11:12:12 EST
This is fixed in utils/mount/nfs.man of upstream nfs-utils (now reads "The fstype field contains "nfs", for whatever version of the  protocol.")  There's been a lot of work on that man page which we may want to incorporate.
Comment 3 Ric Wheeler 2010-11-22 13:43:17 EST
Bruce, can you pull in and update that man page for us?
Comment 6 Jeff Layton 2011-01-19 14:15:01 EST
Looks like this was fixed as a side-effect of Steved's rebase of
nfs-utils to 1.2.3 for bug 637198. Closing as a duplicate of that bug...

*** This bug has been marked as a duplicate of bug 637198 ***

Note You need to log in before you can comment on or make changes to this bug.