Bug 609724 - [abrt] yumex-2.9.8-1.fc14: yum_client.py:542:get_update_info:KeyError: 'updateinfo'
Summary: [abrt] yumex-2.9.8-1.fc14: yum_client.py:542:get_update_info:KeyError: 'updat...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
(Show other bugs)
Version: 14
Hardware: x86_64 Linux
low
medium
Target Milestone: ---
Assignee: Tim Lauridsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:4c8aee1f
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-30 22:20 UTC by Stephen
Modified: 2010-08-19 01:10 UTC (History)
2 users (show)

Fixed In Version: yumex-2.9.10-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-13 21:11:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.07 KB, text/plain)
2010-06-30 22:20 UTC, Stephen
no flags Details

Description Stephen 2010-06-30 22:20:27 UTC
abrt version: 1.1.5
architecture: x86_64
cmdline: /usr/bin/python /usr/share/yumex/yumex.pyc
comment: There was an error in the transaction check, I removed the offending packages from the update and the crash occurred
component: yumex
executable: /usr/share/yumex/yumex.pyc
kernel: 2.6.35-0.2.rc3.git0.fc14.x86_64
package: yumex-2.9.8-1.fc14
reason: yum_client.py:542:get_update_info:KeyError: 'updateinfo'
release: Fedora release 14 (Rawhide)
time: 1277936311
uid: 500

backtrace
-----
yum_client.py:542:get_update_info:KeyError: 'updateinfo'

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/yumexgui/gui.py", line 277, in on_button_clicked
    self.update_console(key)
  File "/usr/lib/python2.6/site-packages/yumexgui/gui.py", line 288, in update_console
    self.show_description()
  File "/usr/lib/python2.6/site-packages/yumexgui/gui.py", line 303, in show_description
    upd_info, updated_po = self.pkg.updateinfo
  File "/usr/lib/python2.6/site-packages/yumexbackend/yum_backend.py", line 440, in updateinfo
    return self._pkg.get_update_info()
  File "/usr/lib/python2.6/site-packages/yumexbackend/__init__.py", line 421, in get_update_info
    return self.base.get_update_info(self.id)
  File "/usr/lib/python2.6/site-packages/yumexbackend/yum_client.py", line 542, in get_update_info
    return msgs['updateinfo'][0],msgs['updated_po'][0]
KeyError: 'updateinfo'

Local variables in innermost frame:
self: <yumexbackend.yum_backend.YumexBackendYum object at 0x2bedf10>
ident: 'libjpeg-turbo-devel\t0\t0.0.93\t10.fc14\tx86_64\trawhide'
msgs: {}

How to reproduce
-----
1. System update using Yumex
2. 
3.

Comment 1 Stephen 2010-06-30 22:20:29 UTC
Created attachment 428128 [details]
File: backtrace

Comment 3 Rudolf Kastl 2010-07-11 13:16:14 UTC
Package: yumex-2.9.9-2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Rawhide)


How to reproduce
-----
1. start yumex
2. select all packages for update
3. watch it unable to resolve deps
4. manually tweak the list of packages to update again
5. try to apply the changes and watch it hang

Comment 4 Tim Lauridsen 2010-07-12 09:15:14 UTC
The modified Status means that the issue is fixed in the yumex git repo, but is not released yet.

Package: yumex-2.9.9-2.fc14 does not contains this fix.

Comment 5 Fedora Update System 2010-07-30 12:16:57 UTC
yumex-2.9.10-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/yumex-2.9.10-1.fc13

Comment 6 Fedora Update System 2010-07-30 12:17:17 UTC
yumex-2.9.10-1.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/yumex-2.9.10-1.fc14

Comment 7 Bug Zapper 2010-07-30 12:21:07 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 8 Fedora Update System 2010-07-30 21:19:26 UTC
yumex-2.9.10-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update yumex'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/yumex-2.9.10-1.fc14

Comment 9 Fedora Update System 2010-08-03 00:36:07 UTC
yumex-2.9.10-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update yumex'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/yumex-2.9.10-1.fc13

Comment 10 Fedora Update System 2010-08-13 21:11:02 UTC
yumex-2.9.10-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2010-08-19 01:09:55 UTC
yumex-2.9.10-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.