Bug 609737 - duplicate directory ownership
duplicate directory ownership
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ggz-gtk-client (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Thomas Janssen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-30 19:38 EDT by Christian Krause
Modified: 2010-07-30 04:44 EDT (History)
2 users (show)

See Also:
Fixed In Version: ggz-gtk-client-0.99.5-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-30 04:36:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Krause 2010-06-30 19:38:48 EDT
Description of problem:
The ggz-gtk-client package owns the directory
/etc/ggz.modules.d/ which is already owned by ggz-base-libs.

This violates the packaging guidelines.

Since ggz-base-libs seems to be a base package which would be required by all other ggz clients which would put files into this directory, the solution should be:

- ggz-gtk-client does not own the directory /etc/ggz.modules.d (only the file /etc/ggz.modules.d/ggz-gtk-client)
- ggz-gtk-client needs to Require ggz-base-libs (which is already implicit the case because of the library dependencies)
- the directory should only be owned by ggz-base-libs

Version-Release number of selected component (if applicable):
ggz-gtk-client-0.99.5-1.fc12.i686

How reproducible:
100%

Steps to Reproduce:
rpm -qf /etc/ggz.modules.d
ggz-base-libs-0.99.5-5.fc12.i686
ggz-gtk-client-0.99.5-1.fc12.i686


The issue is in F12 as well as in F13 (I have not checked RAWHIDE).
Comment 1 Fedora Update System 2010-07-01 06:01:56 EDT
ggz-gtk-client-0.99.5-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/ggz-gtk-client-0.99.5-2.fc13
Comment 2 Fedora Update System 2010-07-01 06:02:04 EDT
ggz-gtk-client-0.99.5-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/ggz-gtk-client-0.99.5-2.fc12
Comment 3 Fedora Update System 2010-07-01 14:39:47 EDT
ggz-gtk-client-0.99.5-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ggz-gtk-client'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/ggz-gtk-client-0.99.5-2.fc13
Comment 4 Fedora Update System 2010-07-01 14:56:02 EDT
ggz-gtk-client-0.99.5-2.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ggz-gtk-client'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/ggz-gtk-client-0.99.5-2.fc12
Comment 5 Fedora Update System 2010-07-30 04:36:00 EDT
ggz-gtk-client-0.99.5-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2010-07-30 04:44:17 EDT
ggz-gtk-client-0.99.5-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.