Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 609741 - QEMU driver doesn't expect "qemu-kvm-devel" as version number
QEMU driver doesn't expect "qemu-kvm-devel" as version number
Status: CLOSED CURRENTRELEASE
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-30 20:27 EDT by vekmitt
Modified: 2011-03-17 10:35 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-17 10:35:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vekmitt 2010-06-30 20:27:57 EDT
Description of problem:
Since I have some problems with qemu-kvm-0.12.4 I was told to try qemu.git. It seems that libvirt parses the version number only in the brackets, e.g. qemu-kvm-0.12.4 returns
> QEMU PC emulator version 0.12.4 (qemu-kvm-0.12.4), Copyright (c) 2003-2008 Fabrice Bellard
but qemu.git returns
> QEMU emulator version 0.12.50 (qemu-kvm-devel), Copyright (c) 2003-2008 Fabrice Bellard


How reproducible:
Use qemu.git instead of an official release of QEMU.

  
Actual results:
libvirt doesn't start the virtual machine at all, it returns the following error (syslog):
> libvirtd: error : qemudParseHelpStr:1341 : internal error cannot parse /usr/bin/qemu-kvm version number in 'QEMU emulator version 0.12.50 (qemu-kvm-devel), Copyright (c) 2003-2008 Fabrice Bellard'


Expected results:
libvirt should start qemu.git just like every other release of QEMU.
Comment 1 Cole Robinson 2010-07-01 10:34:27 EDT
This is fixed upstream, a release just hasn't been cut yet. It should be within a couple weeks.
Comment 2 Cole Robinson 2011-03-17 10:35:41 EDT
Don't know the exact commit, but this has been fixed for a few releases. Closing.

Note You need to log in before you can comment on or make changes to this bug.