Bug 60975 - depends on python2
depends on python2
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-users (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-11 00:30 EST by Chris Ricker
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-11 00:30:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2002-03-11 00:30:23 EST
Is there any good reason for this package to require python2 (as it currently
does) instead of python1.5?  If not, it's annoying and a waste of space for many
users to require both versions of python to be installed....
Comment 1 Brent Fox 2002-03-11 09:20:46 EST
Yes, there are a few reasons.  One is that redhat-config-users uses GTK2. 
Currently, there are only PyGTK2 bindings for Python2.2.  Another reason is that
redhat-config-users uses libuser as the backend, and libuser now requires glib2.
 Since the gtk2 package now requires glib2, and the older gtk1.2 requires glib,
not glib2, it was necessary to use Python2.2/Gtk2 for redhat-config-users.  It
wasn't something I necessarily wanted to do in this timeframe, but it was
necessary.  Welcome to my RPM dependency hell.  ;)

Note You need to log in before you can comment on or make changes to this bug.