Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 609791 - stage 2 frozen on T400
stage 2 frozen on T400
Status: CLOSED DUPLICATE of bug 602207
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
i686 Linux
medium Severity high
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-01 02:35 EDT by Qian Cai
Modified: 2010-07-01 05:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-01 04:49:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Qian Cai 2010-07-01 02:35:54 EDT
Description of problem:
When installing rhel6 beta 2 i386 on T400 laptop, it was frozen right after entering the stage 2 graphical mode. When this happened, ping did not response anymore,

From 10.66.65.14 icmp_seq=205 Destination Host Unreachable


Version-Release number of selected component (if applicable):
kernel-2.6.32-37.el6
RHEL6 beta 2

How reproducible:
always

Steps to Reproduce:
1. install rhel6 beta 2 i386 via graphical mode on T400.
Comment 1 Qian Cai 2010-07-01 04:08:39 EDT
Remote logging seems not help,

Jul  1 16:02:13 dhcp-65-14 rsyslogd: [origin software="rsyslogd" swVersion="4.6.2" x-pid="11611" x-info="http://www.rsyslog.com"] (re)start
Jul  1 16:04:55 INFO     created new libuser.conf at /tmp/libuser.AHOkuq with instPath="/mnt/sysimage"
Jul  1 16:04:55 INFO     anaconda called with cmdline = ['/usr/bin/anaconda', '--stage2', 'http://download.englab.nay.redhat.com/pub/rhel/nightly/RHEL6.0-20100629.n.1/6/Server/i386/os//images/install.img', '--syslog', '10.66.65.14', '--dlabel', '--graphical', '--selinux', '--lang', 'en_US.UTF-8', '--keymap', 'us', '--repo', 'http://download.englab.nay.redhat.com/pub/rhel/nightly/RHEL6.0-20100629.n.1/6/Server/i386/os/']
Jul  1 16:04:55 INFO     Display mode = g
Jul  1 16:04:55 INFO     Default encoding = utf-8 
Jul  1 16:04:56 INFO     Started window manager, pid 747.
Jul  1 16:04:56 WARNING  '/usr/bin/metacity' specified as full path
Jul  1 16:04:56 INFO     Starting graphical installation.
Jul  1 16:04:56 INFO     Detected 1968M of memory
Jul  1 16:04:56 INFO     Swap attempt of 1968M to 3936M
Jul  1 16:04:56 WARNING  step installtype does not exist
Jul  1 16:04:56 WARNING  step confirminstall does not exist
Jul  1 16:04:56 WARNING  step complete does not exist
Jul  1 16:04:57 INFO     moving (1) to step welcome
Comment 2 Qian Cai 2010-07-01 04:21:45 EDT
Looks like X driver bug, as passed usefbx option can workaround it, although it was a very dark screen that seems can't adjust.
Comment 3 Qian Cai 2010-07-01 04:47:13 EDT
Pass intel_iommu=off to the kernel cmdline workaround the problem.
Comment 4 Qian Cai 2010-07-01 04:49:22 EDT

*** This bug has been marked as a duplicate of bug 602207 ***
Comment 5 David Woodhouse 2010-07-01 05:29:58 EDT
I'm not sure this is a duplicate of bug 602207. The expected manifestation of that bug is that the system starts up just fine, but over a long period of time you start to see occasional DMA faults reported as GTT entries get corrupted. 

Working with an installed system is easier -- once it's installed, can you ensure that the IOMMU is enabled again, and show me the dmesg output as it starts up, and X starts?

Note You need to log in before you can comment on or make changes to this bug.