Bug 609857 - CodeAnalyst-gui : does not adhere to Static Library Packaging Guidelines
Summary: CodeAnalyst-gui : does not adhere to Static Library Packaging Guidelines
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: CodeAnalyst-gui (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Parag AN(पराग)
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-01 10:40 UTC by Michael Schwendt
Modified: 2010-07-05 05:16 UTC (History)
2 users (show)

Fixed In Version: CodeAnalyst-gui-2.8.54-22.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-05 05:15:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Schwendt 2010-07-01 10:40:11 UTC
CodeAnalyst-gui-2.8.54-21.fc13.src
is missing
BuildRequires: binutils-static

[...]

https://fedoraproject.org/wiki/Packaging:Guidelines#Packaging_Static_Libraries_2

If a library you depend on only provides a static version your package can link against it provided that you BuildRequire the *-static subpackage. Packagers in such a situation should be aware that if a shared library becomes available, that you should adjust your package to use the shared library.

Comment 1 Parag AN(पराग) 2010-07-05 05:15:53 UTC
Fixed in CodeAnalyst-gui-2.8.54-22.fc14.src


Note You need to log in before you can comment on or make changes to this bug.