Bug 60997 - (SOUND)Distortion in sound while moving windows, clicking buttons,etc
(SOUND)Distortion in sound while moving windows, clicking buttons,etc
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-11 12:28 EST by Andrew McCallum
Modified: 2007-04-18 12:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-15 03:49:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew McCallum 2002-03-11 12:28:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8+) Gecko/20020227

Description of problem:
I am experiencing a good deal of distortion in music files I play with xmms,
mpg123, etc.  Any time I drag a window around, click a button, or do something
like that, there are chirps and other kinds of distortion in the playback.  I've
tried this with or without using esd output, I've tried versions of mpg123
without esd playback, the result is still the same.

System load isn't the problem either - this is on an idle system, and I never
see the cpu loads spike or even approach 25%.  

The system is a dual PIII-400Mhz, 384 MB RAM.  I selected "Install Everything"
on my RH 7.2 install.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start X
2.Start xmms
3.Play some mp3
4.Grab a window and move it around, click buttons, do UI kinds of stuff
	

Actual Results:  Distortion, chirps, playback slowdown is heard in the playback.

Expected Results:  Should not hear distortion in the playback.

Additional info:
Comment 1 Bill Nottingham 2002-03-11 12:42:14 EST
Sounds more like a sound driver (or graphics driver) issue. What chipset?
Comment 2 Andrew McCallum 2002-03-11 12:53:08 EST
The sound card is a generic isa SB clone with an opl3sa2 chip on it.  I've used
this card successfully on a number of linux systems before, up to RH 7.1.  I
just moved the card from my rh 7.1 box to this one.

Video is (according to the nautilus HW browser):
3D Rage IIC 215IIC [Mach64 GT IIC]

I've not used this video card before, but video seems fine to me, and I don't
see performance problems with anything but playing mp3s.

This is also the first time I've used nautilus on my desktop...don't know if
that has anything to do with it.
Comment 3 Michael Schwendt 2002-04-11 10:06:31 EDT
Recently I have experienced the same with XMMS playing mp3s through OSS output
driver while g++ was compiling larger C++ files. All of a sudden I would get
noise/distortion for half a second and then playing again just fine.

Audio chipset here is a CT5880 (Creative Technologies) AC97 codec on GIGABYTE
GA-7ZX (VIA KT133) mainboard:

  es1371: found chip, vendor id 0x1274 device id 0x1371 revision 0x07
  es1371: found es1371 rev 7 at io 0xd800 irq 12
  es1371: features: joystick 0x0
  ac97_codec: AC97 Audio codec, id: 0x8384:0x7608 (SigmaTel STAC9708)

00:0e.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 07)
        Subsystem: Giga-byte Technology: Unknown device 2060
        Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=slow >TAbort- <TAbort-
<MAbort+ >SERR- <PERR-
        Latency: 64 (3000ns min, 32000ns max)
        Interrupt: pin A routed to IRQ 12
        Region 0: I/O ports at d800 [size=64]
        Capabilities: [dc] Power Management version 1
                Flags: PMEClk- DSI+ D1- D2+ AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-


Video is:

01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G400 AGP (rev 04)
(prog-if 00 [VGA])
        Subsystem: Matrox Graphics, Inc. Millennium G400 16Mb SGRAM
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 64 (4000ns min, 8000ns max), cache line size 08
        Interrupt: pin A routed to IRQ 11
        Region 0: Memory at dc000000 (32-bit, prefetchable) [size=32M]
        Region 1: Memory at dfefc000 (32-bit, non-prefetchable) [size=16K]
        Region 2: Memory at df000000 (32-bit, non-prefetchable) [size=8M]
        Expansion ROM at dfee0000 [disabled] [size=64K]
        Capabilities: [dc] Power Management version 2
                Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [f0] AGP version 2.0
                Status: RQ=31 SBA+ 64bit- FW- Rate=x1,x2
                Command: RQ=31 SBA+ AGP+ 64bit- FW- Rate=x1
Comment 4 Need Real Name 2002-11-26 22:51:32 EST
Hi,

I'm seeing this after upgrading to 7.3/2.4.18-18.7.x from 7.2.  Like the
original reporter, the sound cuts out when clicking widgets, moving windows
around, that sort of thing.  It's definitely video and not load related so I'm
not sure the other reporter has the same problem.

I too am running XMMS, decoding MP3s to OSS.


I have an Athlon 900MHz on a Via KT133-based mainboard (ABit KT7).
Sound is SB Live Value, Video is Asus 7700 (GeForce2 GTS).
There are no apparent IRQ or DMA conflicts (don't think either sound or video
use DMA - not sure).  I am using the latest drivers from NVidia.

Let me know if I can provide more information or test anything.  I am willing to
apply kernel patches or anything you might think useful.  This bug is quite
disruptive.


Thanks.


Info from "lspci":

01:00.0 VGA compatible controller: nVidia Corporation NV15 [GeForce2 GTS] (rev
a3) (prog-if 00 [VGA])
	Subsystem: Asustek Computer, Inc.: Unknown device 400e
	Flags: bus master, 66Mhz, medium devsel, latency 248, IRQ 10
	Memory at ec000000 (32-bit, non-prefetchable) [size=16M]
	Memory at e0000000 (32-bit, prefetchable) [size=128M]
	Expansion ROM at <unassigned> [disabled] [size=64K]
	Capabilities: [60] Power Management version 1
	Capabilities: [44] AGP version 2.0

00:09.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 04)
	Subsystem: Creative Labs CT4850 SBLive! Value
	Flags: bus master, medium devsel, latency 32, IRQ 12
	I/O ports at dc00 [size=32]
	Capabilities: [dc] Power Management version 1
Comment 5 Need Real Name 2003-06-14 23:19:20 EDT
This bug no longer occurs for me since upgrading to the 2.4.20 series kernels
(it didn't happen in the 2.4.9 series either).  From my perspective, this is FIXED.

Note You need to log in before you can comment on or make changes to this bug.