Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 610004 - [abrt] kernel: WARNING: at arch/x86/kvm/vmx.c:3320 handle_ept_misconfig+0x220/0x240 [kvm_intel]() (Not tainted)
[abrt] kernel: WARNING: at arch/x86/kvm/vmx.c:3320 handle_ept_misconfig+0x220...
Status: CLOSED DUPLICATE of bug 606131
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
abrt_hash:858255093
:
Depends On:
Blocks: 562808
  Show dependency treegraph
 
Reported: 2010-07-01 08:15 EDT by Mark Wielaard
Modified: 2010-07-14 12:02 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-14 11:16:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (2.64 KB, text/plain)
2010-07-01 08:15 EDT, Mark Wielaard
no flags Details

  None (edit)
Description Mark Wielaard 2010-07-01 08:15:03 EDT
abrt version: 1.1.7
architecture: x86_64
Attached file: backtrace
cmdline: not_applicable
component: kernel
executable: kernel
kernel: 2.6.32-37.el6.x86_64
package: kernel
reason: WARNING: at arch/x86/kvm/vmx.c:3320 handle_ept_misconfig+0x220/0x240 [kvm_intel]() (Not tainted)
release: Red Hat Enterprise Linux release 6.0 Beta (Santiago)
How to reproduce: This seems to happen randomly when running two or more virtual machines, just started through virsh start.  (seen this crash earlier, but was too busy to report it).
time: 1277986180
uid: 0

comment
-----
After the crash the virtual machines are "paused":
$ virsh list
 Id Name                 State
----------------------------------
  1 fedora               paused
  2 rhel6-32             paused

virsh dominfo 1
Id:             1
Name:           fedora
UUID:           ba2b101f-95ab-efe2-9e3d-3aa648b4e5f5
OS Type:        hvm
State:          paused
CPU(s):         4
CPU time:       652.1s
Max memory:     2097152 kB
Used memory:    2097152 kB
Persistent:     yes
Autostart:      disable
Security model: selinux
Security DOI:   0
Security label: system_u:system_r:svirt_t:s0:c446,c884 (enforcing)

$ virsh dominfo 2
Id:             2
Name:           rhel6-32
UUID:           aaa21816-4652-34c5-9491-d69276edceba
OS Type:        hvm
State:          paused
CPU(s):         4
CPU time:       75.0s
Max memory:     2097152 kB
Used memory:    2097152 kB
Persistent:     yes
Autostart:      disable
Security model: selinux
Security DOI:   0
Security label: system_u:system_r:svirt_t:s0:c283,c663 (enforcing)
Comment 1 Mark Wielaard 2010-07-01 08:15:06 EDT
Created attachment 428370 [details]
File: backtrace
Comment 2 Mark Wielaard 2010-07-01 08:29:11 EDT
Some dmesg output just before the backtrace that might be relevant:

EPT: Misconfiguration.
EPT: GPA: 0x37e0b950
ept_misconfig_inspect_spte: spte 0x5e8cb007 level 4
ept_misconfig_inspect_spte: spte 0x5d6d2007 level 3
ept_misconfig_inspect_spte: spte 0x15eeac0f5 level 2
ept_misconfig_inspect_spte: rsvd_bits = 0xac000
Comment 4 RHEL Product and Program Management 2010-07-01 08:43:06 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 5 bottchen 2010-07-08 17:32:25 EDT
Package: kernel
Architecture: x86_64
OS Release: Red Hat Enterprise Linux Server release 6.0 Beta (Santiago)


How to reproduce
-----
1.  2 guests configured, Windows XP and SLES 11
2.  Starting an install of RHEL 5.5 as a 3rd guest put the SLES 11 guest into a paused state.
3.  Each attempt to unpause the SLES 11 guest wrote this backtrace to the syslog before re-pausing the guest.
4.  After a few minutes, libvirtd died and had to be restarted

I later hit the same bug during the RHEL 5.5 install process where the RHEL 5.5 guest itself was put in a paused state.
Comment 6 brenton.oloughlin 2010-07-14 10:41:10 EDT
Package: kernel
Architecture: x86_64
OS Release: Red Hat Enterprise Linux Server release 6.0 Beta (Santiago)


How to reproduce
-----
1. 
2.
3.
Comment 7 brenton.oloughlin 2010-07-14 10:58:27 EDT
Package: kernel
Architecture: x86_64
OS Release: Red Hat Enterprise Linux Server release 6.0 Beta (Santiago)


How to reproduce
-----
Crash occurs on Windows 7 Professional VM on kvm with 768MB virtual memory whilst vm is idle.
Comment 8 Marcelo Tosatti 2010-07-14 11:16:36 EDT

*** This bug has been marked as a duplicate of bug 606131 ***
Comment 9 Andrea Arcangeli 2010-07-14 12:02:10 EDT
And you were running KSM of course.

I wonder if the pause/unpause matters here....

can you test this kernel?

Do you run into swap with KSM or not? Can you check if swap in use is > 0.

http://brewweb.devel.redhat.com/brew/taskinfo?taskID=2586297    

Thanks!

Note You need to log in before you can comment on or make changes to this bug.