Bug 610006 - iwlagn not working in fips mode
iwlagn not working in fips mode
Status: CLOSED DUPLICATE of bug 608704
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: John W. Linville
Red Hat Kernel QE team
:
Depends On:
Blocks: 582655 608704
  Show dependency treegraph
 
Reported: 2010-07-01 08:20 EDT by Jiri Kastner
Modified: 2010-07-06 09:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 09:30:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Kastner 2010-07-01 08:20:35 EDT
when kernel is running in fips mode, iwlagn fails

Version-Release number of selected component (if applicable):
kernel-2.6.32-37.el6.x86_64
wireless-tools-29-5.1.1.el6.x86_64
wpa_supplicant-0.6.8-10.el6.x86_64

How reproducible:
always in fips mode

Steps to Reproduce:
1. enable fips mode
2. reboot
3. 'rmmod iwl{agn,core}
4. 'modprobe iwlagn'
5. run dmesg or tail /var/log/messages

Actual results:
iwlagn: Intel(R) Wireless WiFi Link AGN driver for Linux, 1.3.27k
iwlagn: Copyright(c) 2003-2009 Intel Corporation
iwlagn 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
iwlagn 0000:03:00.0: setting latency timer to 64
iwlagn 0000:03:00.0: Detected Intel Wireless WiFi Link 5100AGN REV=0x54
iwlagn 0000:03:00.0: Tunable channels: 13 802.11bg, 24 802.11a channels
iwlagn 0000:03:00.0: irq 31 for MSI/MSI-X
phy1: Failed to initialize wep: -2
iwlagn 0000:03:00.0: Failed to register hw (error -2)
iwlagn 0000:03:00.0: PCI INT A disabled
iwlagn: probe of 0000:03:00.0 failed with error -2


Expected results:
no error in dmesg, wlan0 visible using iwconfig, ifconfig and NetworkManager
Comment 3 RHEL Product and Program Management 2010-07-01 08:43:11 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 John W. Linville 2010-07-02 09:30:50 EDT

*** This bug has been marked as a duplicate of bug 608704 ***

Note You need to log in before you can comment on or make changes to this bug.