Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 610010 - classAd from createJobTemplate soap method
classAd from createJobTemplate soap method
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: condor (Show other bugs)
Development
All Linux
medium Severity medium
: 1.3
: ---
Assigned To: Matthew Farrellee
Lubos Trilety
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-01 08:32 EDT by Lubos Trilety
Modified: 2010-10-20 07:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lubos Trilety 2010-07-01 08:32:37 EDT
Description of problem:
A job cannot be successfully submitted via soap with classAd created by createJobTemplate method

Version-Release number of selected component (if applicable):
condor-7.4.4-0.4

How reproducible:
100%

Steps to Reproduce:
1. Run createJobTemplate soap method with correctly filled parameters
2. Submit a job via soap with classAd obtained in step 1.
3. Job doesn't run because of undefined 'Env' parameter
  
Actual results:
The job goes to hold state.

Expected results:
The job should run.

Additional info:
output from condor_q -better was
HoldReason = "Failed to convert environment to target syntax for starter (opsys=LINUX): ERROR: Missing '=' after environment variable 'UNDEFINED'."
Comment 1 Matthew Farrellee 2010-07-01 12:20:14 EDT
Pushed upstream, should appear post 7.4.4-0.4
Comment 2 Lubos Trilety 2010-08-06 09:53:36 EDT
Tested with (version):
condor-7.4.4-0.8

Tested on:
RHEL5 x86_64,i386  - passed
RHEL4 x86_64,i386  - passed

>>> VERIFIED

Note You need to log in before you can comment on or make changes to this bug.