Bug 610050 - kvm guest hangs
Summary: kvm guest hangs
Status: CLOSED DUPLICATE of bug 609082
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
high
Target Milestone: rc
: ---
Assignee: Amit Shah
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 580953
TreeView+ depends on / blocked
 
Reported: 2010-07-01 13:17 UTC by Bob Kozdemba
Modified: 2013-01-09 22:48 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-14 12:27:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bob Kozdemba 2010-07-01 13:17:59 UTC
Description of problem:
I'm having a problem where my virtual machines hang. The console and network
are unresponsive. It has happens to several different guests but they are ALL
running an update to date instance of 32-bit rhel5.5. 

Version-Release number of selected component (if applicable):
I've seen this happen with both rhel5.5, rhel6 and f13 hypervisors.

How reproducible:
The vm will hang within a few hours. Virt-manager shows the vm is still running with the cpu usage bouncing between 49-50%.

Steps to Reproduce:
1. virsh start guest
2.
3.
  
Actual results:
The vm console and network become unresponsive.

Expected results:
vm should stay up.

Additional info:
What information can I provide to help debug this? I am running rhel6 on
my laptop and f13 on a server in my lab. I've seen the problem on both
systems. I am only seeing the 32-bit rhel guests hang. I've never seen a windows or 64-bit rhel vm hang.

Comment 2 RHEL Product and Program Management 2010-07-01 13:43:08 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 3 Dor Laor 2010-07-06 12:19:53 UTC
We're not familiar with such a bug.
Please state the qemu-kvm, kernel, seaBios versions.

Comment 4 Bob Kozdemba 2010-07-06 21:22:33 UTC
qemu-kvm-0.12.1.2-2.90.el6.x86_64
kernel-2.6.32-42.el6.x86_64
seabios-0.5.1-2.el6.x86_64

I just updated today against http://download.devel.redhat.com/nightly/latest-RHEL6.0 and still have the problem.

Comment 5 Dor Laor 2010-07-07 09:34:13 UTC
Can you retest with .43 host kernel, we have a fix there for smp guests

Comment 6 Gleb Natapov 2010-07-07 09:40:54 UTC
What's guest kernel version?

Comment 7 Bob Kozdemba 2010-07-07 14:41:21 UTC
Guest kernel is:
Linux server.example.com 2.6.18-194.8.1.el5 #1 SMP Wed Jun 23 10:58:38 EDT 2010 i686 i686 i386 GNU/Linux

I just updated my host to 2.6.32-43 - so far, so good.

Let me know if you need anything else.

Thanks.

Comment 8 Bob Kozdemba 2010-07-08 13:46:11 UTC
I have not seen a hang since upgrading to 2.6.32-43 almost 24 hours ago so this is good news. 

My config is now:
[root@fugue ~]# uname -a
Linux fugue.example.com 2.6.32-43.el6.x86_64 #1 SMP Tue Jul 6 13:50:10 EDT 2010 x86_64 x86_64 x86_64 GNU/Linux
[root@fugue ~]# rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.90.el6.x86_64
[root@fugue ~]# rpm -q seabios
seabios-0.5.1-2.el6.x86_64
[root@fugue ~]#

Will you folks take care of pushing this upstream or should I file a Fedora bug?

The problem still exists on my F13 system (2.6.33.5-124) and fails quickly. 

Thanks.

Comment 9 Amit Shah 2010-07-14 12:27:08 UTC
Closing as dup of the previous bug.

The fix for the kernel hasn't yet been submitted, so Fedora doesn't yet have it. Feel free to open a bug with the Fedora kernel so that it's backported with priority.

*** This bug has been marked as a duplicate of bug 609082 ***


Note You need to log in before you can comment on or make changes to this bug.