Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 610064 - gtk3 apps complain about missing pk-gtk-module
gtk3 apps complain about missing pk-gtk-module
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-01 09:39 EDT by Horst H. von Brand
Modified: 2010-07-14 21:57 EDT (History)
5 users (show)

See Also:
Fixed In Version: PackageKit-0.6.6-2.fc14.x86_64
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-14 21:57:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Horst H. von Brand 2010-07-01 09:39:31 EDT
Description of problem:


Version-Release number of selected component (if applicable):
openoffice.org-calc-3.2.1-19.18.fc14.x86_64 (and others)

How reproducible:
Each time I start OOo calc, writer (haven't tried others)

Steps to Reproduce:
1. Start oocalc
2.
3.
  
Actual results:
Gtk-Message: Failed to load module "pk-gtk-module": libpk-gtk-module.so: cannot open shared object file: No such file or directory

It seems to work fine in any case.

Expected results:
No error message (startup seems to take a lot longer too)

Additional info:
$ rpm -qf /usr/lib64/gtk-2.0/modules/libpk-gtk-module.so
PackageKit-gtk-module-0.6.5-1.fc14.x86_64
$ file /usr/lib64/gtk-2.0/modules/libpk-gtk-module.so
/usr/lib64/gtk-2.0/modules/libpk-gtk-module.so: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, stripped
Comment 1 Caolan McNamara 2010-07-01 09:54:58 EDT
generic gtk3 problem, e.g. launch gnome-power-manager 2>&1 | grep pk-gtk-module

PackageKit-gtk-module only provides a gtk2 module
Comment 2 Richard Hughes 2010-07-01 10:14:11 EDT
Try installing https://admin.fedoraproject.org/updates/PackageKit-0.6.6-1.fc13 -- that installs a gtk2 and gtk3 plugin.
Comment 3 Horst H. von Brand 2010-07-01 10:34:46 EDT
Nope, same messages.
Comment 4 Richard Hughes 2010-07-08 05:13:36 EDT
This is fixed for me using 0.6.6 -- have you restarted your session since you installed the update?
Comment 5 Horst H. von Brand 2010-07-14 21:57:01 EDT
Currently PackageKit-0.6.6-2.fc14.x86_64, messages went away.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.