This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 610128 - Make dhcpd init script LSB compliant
Make dhcpd init script LSB compliant
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dhcp (Show other bugs)
5.7
All Linux
medium Severity medium
: rc
: ---
Assigned To: Jiri Popelka
Release Test Team
:
Depends On: 522134
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-01 11:34 EDT by Martin Poole
Modified: 2011-07-21 05:04 EDT (History)
5 users (show)

See Also:
Fixed In Version: dhcp-3.0.5-27.el5
Doc Type: Bug Fix
Doc Text:
Previously, the dhcpd init script lacked several variables and actions required by the Linux Standard Base (LSB). With this update, the init script has been amended and it is now LSB-compliant.
Story Points: ---
Clone Of: 522134
Environment:
Last Closed: 2011-07-21 05:04:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Martin Poole 2010-07-01 11:34:28 EDT
+++ This bug was initially created as a clone of Bug #522134 +++

Description of problem:
dhcpd has few issues, I'll cover them all in this post.

1) The initscript does not match the template <https://fedoraproject.org/wiki/Packaging/SysVInitScript#Initscript_template> - from what I tested it lacks the exec and config variables

2) force-reload action is not implemented

3) stop action on stopped dhcpd returns 7 instead of 0

How reproducible:
always

Steps to Reproduce:
1. service dhcpd start
2. service dhcpd stop
3. service dhcpd stop
  
Actual results:
The second stop returns 7

Expected results:
The second stop returns 0

--- Additional comment from tfu@redhat.com on 2009-11-02 19:52:35 EST ---

User jskladan@redhat.com's account has been closed
Comment 1 RHEL Product and Program Management 2010-09-13 11:37:59 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 8 Alexander Todorov 2011-05-09 05:16:22 EDT
# rpm -q dhcp
dhcp-3.0.5-29.el5

# service dhcpd status
dhcpd is stopped

# service dhcpd stop  
# echo $?
0
Comment 9 Tomas Capek 2011-05-31 04:17:52 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, the dhcpd init script lacked several variables and actions required by the Linux Standard Base (LSB). With this update, the init script has been amended and it is now LSB-compliant.
Comment 10 errata-xmlrpc 2011-07-21 05:04:01 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1038.html

Note You need to log in before you can comment on or make changes to this bug.