Bug 61014 - Logrotate fails when looking for pacct
Logrotate fails when looking for pacct
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: logrotate (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-11 18:41 EST by Mike Chambers
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-11 18:41:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Chambers 2002-03-11 18:41:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
When /etc/cron.daily/logrotate runs, it can't find /var/log/pacct because the 
file isn't there.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run /etc/cron.daily/logrotate
2.
3.
	

Actual Results:  stat of /var/log/pacct failed: No such file or directory

Expected Results:  No errors reported when logrotate runs and the logs are 
rotated flawlessly.

Additional info:

The fix seems to be located in /etc/logrotate.d/psacct by replacing all lines 
with /var/log/psacct to /var/account/psacct, or to create a symlink.
Comment 1 Mike Chambers 2002-03-25 08:59:45 EST
Closing this, and marking as fixed in rawhide, as don't see error on beta 3.

Note You need to log in before you can comment on or make changes to this bug.