Bug 610166 - Slow performances while using math formula
Summary: Slow performances while using math formula
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
(Show other bugs)
Version: 13
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-01 16:53 UTC by Germano Massullo
Modified: 2010-10-19 15:13 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-19 15:13:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 112194 None None None Never

Description Germano Massullo 2010-07-01 16:53:53 UTC
When I use the math formula, the writer performances reduce drastically and 
everything in the writer is so slow!
I attach the document I am writing in.
The OpenOffice version is 3.2.0 with Fedora 13, and I don't know how is the 
version of writer I have to select here.

I have this problem on both my pc.

I've previously reported this bug on Openoffice.org bug report website, but it seems that the problem is only on Fedora packages.
http://www.openoffice.org/issues/show_bug.cgi?id=112194

Comment 1 Caolan McNamara 2010-07-01 16:59:52 UTC
They're just using the CrazyDistroDefense http://wiki.services.openoffice.org/wiki/CrazyDistroDefense

Comment 2 yemmi 2010-07-01 17:18:50 UTC
same problem for me with caterpillar's .odt attachment

fedora 13 and oo.o 3.2.0
intel i5 4gb ram

Comment 3 Caolan McNamara 2010-07-01 19:25:06 UTC
Its no speed demon on this document I'll admit, but what specifically was sufficiently slow to drive you to report this. The redraw of equations when scrolling down the page ? Performance issues are hard to fix to everyone satisfaction when it can be uncertain as to what needs to be improved. Can you assign some objective number to something exact, e.g. "it takes X seconds to do Y"

Here's some variables to play with to see if they make a difference.

export SAL_DISABLE_FC_SUBST=1
export SAL_DISABLE_CAIROTEXT=1

Comment 4 Germano Massullo 2010-07-01 20:01:15 UTC
Before assigning some objective number to actions like "it takes X seconds to do
Y" I would try before the two settings you suggested me.
Where can I insert them? In which specific config file?

Comment 5 Caolan McNamara 2010-07-01 20:13:18 UTC
shutdown office, launch a terminal e.g. gnome-terminal and just cut and paste

 e.g
export SAL_DISABLE_CAIROTEXT=1
return
and then
oowriter
return
to try out that environmental variable on its own.

Comment 6 Germano Massullo 2010-07-01 21:16:51 UTC
Done with 
export SAL_DISABLE_FC_SUBST=1
export SAL_DISABLE_CAIROTEXT=1
Nothing changes.
It takes at least 1-2 seconds to show some parts of the document. I have a newer version of the document with lot of new formulas

Comment 7 Germano Massullo 2010-09-05 20:40:59 UTC
Will this bug fixed in Fedora 14?

Comment 8 Germano Massullo 2010-09-05 21:05:39 UTC
Actually I am forced to use the RPM of OpenOffice 3.2.1 provided by Oracle in openoffice.org website. That version seems to work on my desktop pc and has NOT slow performances on formulas, I can scroll very smothly without problems.

Comment 9 Caolan McNamara 2010-09-06 08:04:15 UTC
Well, if vanilla 3.2.1 is not slow but the Fedora one is, then it is presumably the fontconfig work which is causing it (though I don't see the slowdown myself) in which case this work is integrated into 3.3.0 as in F-14 and in vanilla so either the vanilla 3.3.X will be just as slow as the fedora one, or the extra optimizations added during 3.3.X will fix the problem.

i.e. either way I expect F-14 3.3.0 to be the same as vanilla 3.3.0 speedwise

Comment 10 Caolan McNamara 2010-10-19 15:13:06 UTC
Must be the fontconfig work. Which got merged into the "vanilla" OpenOffice.org as well now, so both render the same way from 3.3 onwards


Note You need to log in before you can comment on or make changes to this bug.