Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 610168 - [abrt] crash in fontforge-20090923-3.fc13: _GXPDraw_configfont: Process /usr/bin/fontforge was killed by signal 11 (SIGSEGV)
[abrt] crash in fontforge-20090923-3.fc13: _GXPDraw_configfont: Process /usr/...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fontforge (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
abrt_hash:4adc61ee8effdb5871490020b15...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-01 13:04 EDT by Paul Flo Williams
Modified: 2010-08-03 11:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-03 11:25:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (29.10 KB, text/plain)
2010-07-01 13:04 EDT, Paul Flo Williams
no flags Details

  None (edit)
Description Paul Flo Williams 2010-07-01 13:04:04 EDT
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: fontforge /usr/share/fonts/dejavu/DejaVuSans.ttf
component: fontforge
crash_function: _GXPDraw_configfont
executable: /usr/bin/fontforge
global_uuid: 4adc61ee8effdb5871490020b15a086492ed418c
kernel: 2.6.33.5-124.fc13.x86_64
package: fontforge-20090923-3.fc13
rating: 4
reason: Process /usr/bin/fontforge was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

comment
-----
Attempting to edit DejaVuSans.ttf from installed package dejavu-sans-fonts-2.31-1.fc13.noarch

The two steps given will always crash FontForge.

How to reproduce
-----
1. fontforge /usr/share/fonts/dejavu/DejaVuSans.ttf
2. Select Hints -> Edit 'cvt' ...

cvt window displays briefly, then fontforge dies.
Comment 1 Paul Flo Williams 2010-07-01 13:04:07 EDT
Created attachment 428496 [details]
File: backtrace
Comment 2 Paul Flo Williams 2010-07-03 15:14:00 EDT
This crash is not happening with current CVS pull, sources from 2010-06-25.
Comment 3 Kevin Fenzi 2010-07-04 15:17:16 EDT
Greetings.

Can you please upgrade to the version in this scratch build:

http://koji.fedoraproject.org/koji/taskinfo?taskID=2294313

and see if the problem re-occurs or is fixed?

Note that this build will only be around for a few weeks.

Thanks. That should isolate if it's fixed in that release or we need to wait for the next one.
Comment 4 Paul Flo Williams 2010-07-04 15:50:59 EDT
Fixed in that scratch build, thanks. The cvt window now appears, is populated and is resizable.

(I mention resizing because it appears that this build will also fix bug 572427.)
Comment 5 Paul Flo Williams 2010-08-03 02:33:20 EDT
I think the fact that this is fixed in your scratch build means that this is fixed in Rawhide and can be closed?
Comment 6 Kevin Fenzi 2010-08-03 11:25:29 EDT
Yep. Sounds good to me. :) 

Thanks so much for reporting it.

Note You need to log in before you can comment on or make changes to this bug.