Bug 610185 - Yum cannot complete updates
Yum cannot complete updates
Status: CLOSED INSUFFICIENT_DATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum (Show other bugs)
5.5
x86_64 Linux
low Severity urgent
: rc
: ---
Assigned To: James Antill
BaseOS QE Security Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-01 13:43 EDT by Trevor Cooper
Modified: 2014-01-21 01:18 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-01 15:06:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Trevor Cooper 2010-07-01 13:43:57 EDT
Description of problem:

Attempt to complete update of machine is not successful

Version-Release number of selected component (if applicable):

[root@ip109 /]# yum -v
Loading "dellsysidplugin2" plugin
Loading "rhnplugin" plugin
Loading "security" plugin
Config time: 0.086
Yum Version: 3.2.22
You need to give some command

How reproducible:

100%


Steps to Reproduce:
1. yum update yum
2. yum install yum-utils
3. yum clean all
4. yum update
  
Actual results:

[root@ip109 /]# yum update
Loaded plugins: dellsysidplugin2, rhnplugin, security
Skipping security plugin, no data
Setting up Update Process
Resolving Dependencies
Skipping security plugin, no data
--> Running transaction check
---> Package libsmbios.i386 0:2.2.19-10.1.el5 set to be updated
---> Package libsmbios.x86_64 0:2.2.19-10.1.el5 set to be updated
---> Package python-smbios.x86_64 0:2.2.19-10.1.el5 set to be updated
---> Package smbios-utils-bin.x86_64 0:2.2.19-10.1.el5 set to be updated
---> Package smbios-utils-python.x86_64 0:2.2.19-10.1.el5 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                Arch      Version              Repository          Size
================================================================================
Updating:
 libsmbios              i386      2.2.19-10.1.el5      dell-omsa-indep    1.5 M
 libsmbios              x86_64    2.2.19-10.1.el5      dell-omsa-indep    1.5 M
 python-smbios          x86_64    2.2.19-10.1.el5      dell-omsa-indep     69 k
 smbios-utils-bin       x86_64    2.2.19-10.1.el5      dell-omsa-indep    117 k
 smbios-utils-python    x86_64    2.2.19-10.1.el5      dell-omsa-indep     56 k

Transaction Summary
================================================================================
Install       0 Package(s)
Upgrade       5 Package(s)

Total size: 3.2 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
libsmbios is needed by (installed) smbios-utils-bin-2.2.19-4.1.el5.i386
libsmbios is needed by (installed) smbios-utils-bin-2.2.19-4.1.el5.i386
Complete!
(1, [u'Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Red%20Hat%20Enterprise%20Linux%205&component=yum'])

Expected results:

Update success.

Additional info:
Comment 1 seth vidal 2010-07-01 13:50:57 EDT
please run:

rpm -Va --nofiles --nodigest


and report the output.
Comment 2 Trevor Cooper 2010-07-01 14:12:17 EDT
[root@ip109 ~]# rpm -Va --nofiles --nodigest

... No output ...

[root@ip109 ~]# history | grep nodigest
   221  rpm -Va --nofiles --nodigest
   433  rpm -Va --nofiles --nodigest
   501  rpm -Va --nofiles --nodigest
   502  history | grep --nodigest
   503  history | grep nodigest

This had been run with no output BEFORE the bug report with no output. Same result now...

~~~~ Solution ~~~~

Solution was to uninstall packages that needed updates then reinstall 
entire Dell OMSA 6.2 package.

   456  yum update yum
   457  yum install yum-utils
   458  yum clean all
   459  yum update
   460  yum -v

... Bug Report Filed Here ...

   461  clear
   462  yum update
   463  wget -q -O - 
http://linux.dell.com/repo/hardware/OMSA_6.2/bootstrap.cgi | bash

... Same error as in bug report ...

   464  yum remove libsmbios python-smbios smbios-utils-bin 
smbios-utils-python

... Successfully removed ...

   465  wget -q -O - 
http://linux.dell.com/repo/hardware/OMSA_6.2/bootstrap.cgi | bash

... Successfully installed 'new' Dell OMSA repo ...

   466  yum install srvadmin-all
   467  yum install srvadmin-all --disablerepo=rpmforge

... Successfully installed 'new' Dell OMSA tools ...

   468  yum check-update

... No more updates ...

   469  exit
   470  srvadmin-services.sh  start
   471  firefox https://localhost:1311/ &
   472  admin_mount
   473  /admin/scripts/omalert_set.sh
   474  ls /bin/omalert*
   475  vim /bin/omalert
   476  rm /bin/omalert
   477  vim /bin/omalert-hardware
   478  vim /bin/omalert-hardware
   479  vim /bin/omalert-power
   480  vim /bin/omalert-storage
   481  vim /bin/omalert-temp
   482  /bin/omalert-hardware Test
   483  /bin/omalert-power Test
   484  /bin/omalert-storage Test
   485  /bin/omalert-temp Test
   486  ls /admin/scripts/
   487  omconfig system thrmshutdown severity=failure
   488  omreport system thrmshutdown
   489  chkconfig --level 345 nfs on
   490  service nfs start
   491  service nfs stop
   492  ls /var/lib/nfs/rmtab
   493  cat /var/lib/nfs/rmtab
   494  cat /dev/null > /var/lib/nfs/rmtab
   495  cat /var/lib/nfs/rmtab
   496  service nfs start
   497  cat /var/lib/nfs/rmtab
   498  cat /var/lib/nfs/rmtab
   499  cat /var/lib/nfs/rmtab
   500  exit

... More info request ...

   501  rpm -Va --nofiles --nodigest
   502  history | grep --nodigest
   503  history | grep nodigest
   504  history | tail -30
   505  history | tail -50

Can no longer reproduce bug...

[root@ip109 ~]# yum update
Loaded plugins: dellsysid, rhnplugin, security
Skipping security plugin, no data
Setting up Update Process
No Packages marked for Update
[root@ip109 ~]# rpm -qa redhat-release
redhat-release-5Server-5.5.0.2
[root@ip109 ~]# cat /etc/redhat-release
Red Hat Enterprise Linux Server release 5.5 (Tikanga)

Really a bug?
Comment 3 seth vidal 2010-07-01 15:06:45 EDT
I can't really tell at this point. Any information on what was happening appears to now be gone.

Note You need to log in before you can comment on or make changes to this bug.