Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 61021 - bootnet.img 'ps' gives glibc relocation error
bootnet.img 'ps' gives glibc relocation error
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-12 07:44 EST by Pekka Savola
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-12 22:40:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pekka Savola 2002-03-12 07:44:57 EST
TUI boonet upgrade.

Hit ALT-F2 to access the shell.

'ps' errors out:

ps: relocation error: /mnt/sysimage/lib/libnss_compat.so.2: symbol:
_nss_files_parse_pwent: version
GLIBC_2.0 not defined in file libc.so.6 with link time reference.

Smells like a build problem (possibly gone away with never glibc) of the
floppies..
Comment 1 Jeremy Katz 2002-03-12 21:49:38 EST
No, it's much more interesting than that actually :-)

Basically, ps runs and is dynamically linked against libc.  When you go to do
lookups of user ids after the stat() call, glibc recurses through
LD_LIBRARY_PATH looking for nss modules and finds the one in your previously
installed system.  The two glibcs are fairly significantly different, thus you
get errors from glibc.

It looks like actually adding an explicit nsswitch.conf in the initrd that only
looks at files fixes the problem so I'll get that into the scripts shortly
Comment 2 Jeremy Katz 2002-03-12 22:40:14 EST
Fixed
Comment 3 Jay Turner 2002-03-13 10:50:03 EST
Confirmed fixed in the Hampton-re0312.0 tree.

Note You need to log in before you can comment on or make changes to this bug.