Bug 610214 - don't ship /etc/dbus-1/system.d/gnome-power-manager.conf [NEEDINFO]
don't ship /etc/dbus-1/system.d/gnome-power-manager.conf
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gnome-power-manager (Show other bugs)
5.7
All Linux
low Severity medium
: rc
: ---
Assigned To: Richard Hughes
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-01 14:51 EDT by Colin Walters
Modified: 2014-06-02 09:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:03:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (walters)


Attachments (Terms of Use)

  None (edit)
Description Colin Walters 2010-07-01 14:51:55 EDT
g-p-m ships a file on RHEL5 which allows an @console session to claim org.gnome.PowerManager, but it doesn't appear to actually connect to the system bus and claim this name.

This file should just be removed if that is indeed the case.
Comment 1 Richard Hughes 2010-07-02 03:45:23 EDT
Yes agreed. I think this was an unused relic that dates to right to when g-p-m started using dbus. It's certainly not been in VCS for years now, but I guess it's still in the version shipped in RHEL5.

If we get the required acks it would be trivial to remove this from the binary package.
Comment 2 RHEL Product and Program Management 2014-03-07 08:34:53 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 3 RHEL Product and Program Management 2014-06-02 09:03:20 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.