Bug 61024 - up2date fails to run
up2date fails to run
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-12 08:06 EST by Tim Wunder
Modified: 2015-01-07 18:55 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-09 09:51:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Wunder 2002-03-12 08:06:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.9+)
Gecko/20020308

Description of problem:
Executing 'up2date' exits with this error:

Traceback (innermost last):
File "/usr/sbin/up2date", line 12, in ?
import xmlrpclib
File "/usr/lib/python1.5/sire-packages/xmlrpclib.py", line 28, in ?
import urllib, xmllib
File "/usr/lib/python1.5/urllib.py", line 25, in ?
import socket
ImportError: symbol __sysconf, version GLIBC_2.2 not defined in file libc.so.6
with link time reference

libc.so.6 is a symlink to libc-2.1.92.so
I have python-xmlrpc-1.5.1-7.x.3 installed


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. run ep2date
2.
3.
	

Additional info:
Comment 1 Adrian Likins 2002-05-08 17:08:30 EDT
You will need to update to the latest glibc by hand.
Comment 2 Tim Wunder 2002-05-09 09:51:19 EDT
OK. Some quick questions, though:

When updating glibc from RPM, is it a good idea to force the update with 'rpm -Uvh --force'?

Then again, would I be better served by updating to  RedHat 7.3, and starting from a more current code base?

If so, is it feasible to update 7.0 to 7.3, or would a reinstall be recommended?
Comment 3 Adrian Likins 2002-08-08 23:10:33 EDT
No need to use "--force" to upgrade glibc (I would stronly recomended
against useing it with rpm....)


Note You need to log in before you can comment on or make changes to this bug.