Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 610249 - RFE: notification about changes in the inferior process
RFE: notification about changes in the inferior process
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gdb (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Sergio Durigan Junior
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-01 16:25 EDT by Dave Malcolm
Modified: 2018-06-28 17:03 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-06-28 17:03:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Malcolm 2010-07-01 16:25:33 EDT
(This is more of an RFE for the upstream gdb-archer project, but filing here since I need this for a Fedora 14 feature, and IIRC I was told in on IRC by pmuldoon that filing such requests here was OK by him)

I'm calculating lots of expensive-to-compute data in Python code about the state of the inferior process, and ideally it would be cached until the user does "next", "step" or "continue": anything that could affect the state of the inferior process.

Is there any way to be notified when I need to invalidate a cache?  Perhaps a way to register a callback that can be called when the inferior process changes, or could change (which perhaps returns a boolean to gdb indicating whether it should be removed?)

tromey on IRC mentioned "hook-stop" and "hook-run"
<tromey> but these aren't ideal, the user might want to use them

Thoughts?
Comment 2 Fedora Admin XMLRPC Client 2011-01-05 22:21:43 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Tom Tromey 2011-05-17 13:58:14 EDT
Upstream gdb has a 'gdb.events' module that exposes various events
to Python.  The current events are cont (when inferior continues),
exited (inferior exits), and stop (inferior stops).
That might be enough for your purposes; but if not, please let us know
what else you need.
Comment 4 Jan Kratochvil 2012-01-05 16:25:19 EST
Is this complete or not?
Comment 5 Sergio Durigan Junior 2018-06-28 16:53:44 EDT
Pinging the bug to see if it's still valid.  I'll wait a few weeks, and then close it if no response is given.  Thanks.
Comment 6 Dave Malcolm 2018-06-28 17:03:35 EDT
This was for use by gdb-heap, but that project is dormant, and the necessary hooks may well already exist, as per comment #3.

Closing this out as WORKSFORME.

Note You need to log in before you can comment on or make changes to this bug.