Bug 61025 - logrotate error when extension is given
Summary: logrotate error when extension is given
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: logrotate (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: All Linux
high
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-12 13:31 UTC by Need Real Name
Modified: 2007-03-27 03:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-02 22:57:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-03-12 13:31:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; Linux 2.4.17-0.13 i686)

Description of problem:
Hi,
I have configured daily logrotating for a customer of our company. I have turned
on compression and defined the extension .gz under RedHat 7.1 this combination
works fine.

Now under RedHat 7.2 I get some errors:

gzip: /var/log/messages.1.gz already has .gz suffix -- unchanged failed to
compress log /var/log/messages.1.gz
and so on.

Now logrotate doesn't create messages.2.gz and the logfile is lost.

When there is no parameter extension .gz in the logrotate.conf everything works
fine.

greetings markus

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. configure in logrotate.conf extension .gz
2. configure in logrotate.conf daily
3. configure in logrotate.conf compress
4. now run logrotation set the date to the next day run it again and once more
now you see my problem

Expected Results:  i have expected the same result as in redhat 7.1, there it
works perfect.

Additional info:

Comment 1 Elliot Lee 2002-04-15 20:21:13 UTC
Can't reproduce, I'm gonna take a wild guess that this has since been addressed.
Please try logrotate-3.6.4 when it shows up in rawhide.


Note You need to log in before you can comment on or make changes to this bug.