Bug 610256 - duplicate directory ownership
duplicate directory ownership
Status: CLOSED DUPLICATE of bug 569414
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Andreas Schwab
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-01 16:50 EDT by Christian Krause
Modified: 2010-07-02 09:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 09:12:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Krause 2010-07-01 16:50:26 EDT
Description of problem:

- glibc-common owns the directory /usr/lib/locale which is already owned by the filesystem package (violation against the packaging guidelines for directory ownership)

rpm -qf /usr/lib/locale
filesystem-2.4.30-2.fc12.i686
glibc-common-2.11.2-1.i686

- glibc-common includes this directory with a different set of permissions than the filesystem package

glibc-common: 755
filesystem: 555

and so I have stumbled over the problem by doing:

rpm -V filesystem
.M.......    /usr/lib/locale


Version-Release number of selected component (if applicable):
glibc-common-2.11.2-1.i686

How reproducible:
100%

Additional info:
- the following commit fixed the problem in F13 by removing /usr/lib/locale from the %files section of glibc.spec
http://cvs.fedoraproject.org/viewvc/rpms/glibc/F-13/glibc.spec?r1=1.430&r2=1.431&view=patch
Comment 1 Andreas Schwab 2010-07-02 09:12:27 EDT

*** This bug has been marked as a duplicate of bug 569414 ***

Note You need to log in before you can comment on or make changes to this bug.