Bug 610257 - a2ps isn't UTF8-clean
Summary: a2ps isn't UTF8-clean
Status: CLOSED DUPLICATE of bug 71496
Alias: None
Product: Fedora
Classification: Fedora
Component: a2ps   
(Show other bugs)
Version: 14
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-01 20:50 UTC by Horst H. von Brand
Modified: 2010-08-23 11:14 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-23 11:14:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A file with UTF8 (127 bytes, application/octet-stream)
2010-07-01 20:50 UTC, Horst H. von Brand
no flags Details

Description Horst H. von Brand 2010-07-01 20:50:30 UTC
Created attachment 428561 [details]
A file with UTF8

Description of problem:
Printing a textfile (like the attached one) gives gibberish, the non-ASCII caracters are interpreted as 2 weird characters each.

Version-Release number of selected component (if applicable):
a2ps-4.14-11.fc14.x86_64

How reproducible:
Each time you try to print an non-ASCII text...

Steps to Reproduce:
1. a2ps -1 --output=testfile.ps
2.
3.
  
Actual results:
Gibberish in testfile.ps

Expected results:
A reasonable representation of the original text

Additional info:

Comment 1 Bug Zapper 2010-07-30 12:22:56 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 2 Tim Waugh 2010-08-23 11:14:05 UTC

*** This bug has been marked as a duplicate of bug 71496 ***


Note You need to log in before you can comment on or make changes to this bug.