Bug 6103 - ypbind does not find users properly
ypbind does not find users properly
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: ypbind (Show other bugs)
6.1
i386 Linux
low Severity low
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-19 17:56 EDT by adler
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-03 21:39:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description adler 1999-10-19 17:56:32 EDT
I just had a strange insident. A user came by complaining
that he
couldn't log into one of our linux boxes. All of them use
NIS which
is served from an SGI system running IRIX 5.3. I tried doing
an
su - username and got the error that the username was not a
valid
one.(the extact text of the mssage was "su: user username
does not exist")
But it did work on the other linux boxes. I then restarted
ypbind
(i.e.

  cd /etc/rc.d/init.d
  ./ypbind restart

)

and the su command worked. Before doing the ypbind restart,
I did try
out one other account and the su into that account did work.

If this happens again, is there a better way of diagnosing
the problem?

Steve.
Comment 1 Cristian Gafton 2000-02-03 21:39:59 EST
ypbind takes a while (~1min) to detect that an NIS server is down and to connect
to another one, and then if and only if the /etc/yp.conf permits broadcasting
for a certain domain

Note You need to log in before you can comment on or make changes to this bug.