Bug 6104 - pty allocation leak
pty allocation leak
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: dev (Show other bugs)
6.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-19 18:42 EDT by scott.edwards
Modified: 2014-03-16 22:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-13 17:20:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description scott.edwards 1999-10-19 18:42:19 EDT
Some program is causing a pty leak which leaves the system
in a state that will no longer allow programs like expect,
screen or normal logins via ssh or telnet to function.

I think the problem lies either in "expect" "autoexpect" or
one of it components.  For the last week or so I have been
experementing with these tools, and eventually got this
error while running an expect script.

The system has no more ptys.  Ask your system administrator
to create more
     While executing ftp
"spawn ftp"
     (file /home/user/bin/ftp-sync.exp" line x)

I tried cycling init states to 1 and back to 3 to see if
that could help resolve the problem.  That did not work.

I asked about this in #linux on efnet, and one other user
mentioned that he gets this error with screen quite often.

Regards - Supaplex
Comment 1 Bill Nottingham 1999-10-19 22:34:59 EDT
Do you have more than 256 login sessions running?
Comment 2 Bill Nottingham 1999-10-19 22:38:59 EDT
What does /dev/pts look like - does it have 256 allocated ptys?
Comment 3 scott.edwards 1999-10-19 23:54:59 EDT
I have never used more then 20 ptys on this system.  My latest kernel
was compiled for support of 64 ptys in relation to that fact.

The directory below /dev/pts is empty.
Comment 4 scott.edwards 1999-10-20 00:28:59 EDT
I have never used more then 20 ptys on this system.  My latest kernel
was compiled for support of 64 ptys in relation to that fact.

The directory below /dev/pts is empty.
Comment 5 Bill Nottingham 1999-10-20 12:27:59 EDT
What does an strace of an affected program look like?
Comment 6 Preston Brown 2000-01-13 17:20:59 EST
closed due to lack of feedback.

Note You need to log in before you can comment on or make changes to this bug.