Bug 61040 - FTP install: can't select network device driver
FTP install: can't select network device driver
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks: 61590
  Show dependency treegraph
 
Reported: 2002-03-12 11:25 EST by Danny Trinh
Modified: 2007-04-18 12:40 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-26 11:51:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Danny Trinh 2002-03-12 11:25:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 98)

Description of problem:
When using expert noprobe mode on FTP installation (bootnet.img), I can't see a 
list of network device to add in during installation.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.PE1650 + ROMB + e100 NIC + onboard E1000 NICs.
2.Boot from bootnet.img, and do "expert noprobe" mode.
3.Add ROMB driver, and then continue trying to add NIC drivers.
	

Actual Results:  Can't install E1000 driver during install by using expert 
noprobe mode

Expected Results:  Must be able to add NIC drivers + seeing a list of NIC 
drivers.

Additional info:
Comment 1 Jeremy Katz 2002-03-13 14:53:28 EST
e1000 is on the driver disk and not bootnet, so you'd need 'noprobe dd' (expert
is largely irrelevant).  If you just do noprobe, you should get the dialog and
be able to hit F2 to use the driver disk.  This definitely appears to be working
for me here, so if you could confirm that it's just that e1000 isn't on bootnet
(which it won't be) or if there's something else going on, that would be great
Comment 2 Danny Trinh 2002-03-13 14:59:35 EST
I just use e1000 as a sample. I don't see a list of NIC drivers, when I 
use "expert noprobe" mode. If I use broadcom NIC card, I still can't pick the 
driver, because there is no list of NIC drivers show up.
Comment 3 Jeremy Katz 2002-03-14 18:24:14 EST
Hrmm... this is working for me here on my test machine.   I'll try to remember
to do it as I'm doing some testing on other machines to see if I can reproduce
the problems there
Comment 4 John A. Hull 2002-03-15 15:43:35 EST
There may be some confusion on this. Here are the exact steps/screens:

1. "expert noprobe" at boot prompt
2. No to driver disk, choose English, us keyboard
3. Choose FTP
4. Devices screen--> choose driver for NIC
5. connect to server in next 2 screens
6. You get a Devices screen that says that no special device drivers have been 
loaded. Choose "Add Device"
7. Choose "Network" to add a network device
8. Choose "No" for using a driver disk
You are then kicked out to the SCSI/Network screen instead of being able to 
choose from a list of devices.
Comment 5 Jeremy Katz 2002-03-18 14:45:22 EST
Aha, with that information, I can reproduce it.  Thanks, I'll look into it some
more to try to see what's going on.
Comment 6 Danny Trinh 2002-03-21 15:07:30 EST
not fixed in beta3
Comment 7 Jeremy Katz 2002-03-21 15:23:11 EST
Since we froze last week, nope...  it's on my list of things to fix, though. 
Just haven't gotten there due to things which require string/screen freezes
needing to be done first.
Comment 8 Jeremy Katz 2002-03-27 01:42:36 EST
This behavior is actually as expected.  There are only additional network
drivers on the NFS install images and this is identical to the 7.2 behavior. 
Adding all of the network drivers to the FTP image would add over a meg to the
ramdisk size and thus bump up the memory requirements similarly.  To get network
drivers other than the ones on bootnet.img with an FTP install, you have to use
a driver disk.

Note You need to log in before you can comment on or make changes to this bug.