Bug 61044 - multiport documentation bug
multiport documentation bug
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: iptables (Show other bugs)
7.2
All Linux
low Severity low
: ---
: ---
Assigned To: Harald Hoyer
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-12 11:51 EST by Nigel Metheringham
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-12 10:29:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
iptables man page patch for multiport extension (654 bytes, patch)
2002-03-12 11:51 EST, Nigel Metheringham
no flags Details | Diff

  None (edit)
Description Nigel Metheringham 2002-03-12 11:51:02 EST
Current RH version of iptables - iptables-1.2.4-2 - misdocuments the multiport
extension.  All of the --*port options should actually be --*ports (ie with
and additional s).   If used as documented the error message is strange because
the options given are legal for the tcp/udp module.

Patch attached corrects this part of the man page, and gives --sports as a
synonym for --source-ports as well.
Comment 1 Nigel Metheringham 2002-03-12 11:51:52 EST
Created attachment 48286 [details]
iptables man page patch for multiport extension
Comment 2 Harald Hoyer 2002-08-12 09:43:53 EDT
huh???
# iptables -m tcp --help
iptables v1.2.6a
....
 --source-port [!] port[:port]
 --sport ...
                                match source port(s)
 --destination-port [!] port[:port]
 --dport ...
                                match destination port(s)


since when is that????
Comment 3 Nigel Metheringham 2002-08-12 10:29:50 EDT
Its for *multiport* as the original bug said.

/sbin/iptables --proto tcp --match multiport --help
[...]
multiport v1.2.5 options:
 --source-ports port[,port,port...]
 --sports ...
				match source port(s)
 --destination-ports port[,port,port...]
 --dports ...
				match destination port(s)
 --ports port[,port,port]
				match both source and destination port(s)
Comment 4 Harald Hoyer 2002-08-12 10:36:00 EDT
seems to be already fixed in 
$ rpm -q iptables
iptables-1.2.6a-1

$ man iptables
...
   multiport
       This  module  matches  a  set of source or destination ports.  Up to 15
       ports can be specified.  It can only be used in conjunction with -p tcp
       or -p udp.

       --source-ports port[,port[,port...]]
              Match  if  the  source port is one of the given ports.  The flag
              --sports is a convenient alias for this option.

       --destination-ports port[,port[,port...]]
              Match if the destination port is one of the  given  ports.   The
              flag --dports is a convenient alias for this option.

       --ports port[,port[,port...]]
              Match  if the both the source and destination ports are equal to
              each other and to one of the given ports.
...


Note You need to log in before you can comment on or make changes to this bug.