Bug 61046 - using [TAB] along with the "cd" command should only regard directories
Summary: using [TAB] along with the "cd" command should only regard directories
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bash   
(Show other bugs)
Version: 7.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: wdovlrrw
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-12 17:11 UTC by Hakon
Modified: 2007-04-18 16:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-13 17:47:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Hakon 2002-03-12 17:11:05 UTC
Description of Problem:


Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. set up a directory with 2 empty txt files called: Linux-1 ; Linux-2 and then
a directory called Linux-dir
2. type "cd Li" ; press tab
3. 

Actual Results: "Linux-" is filled in, and there's a beep


Expected Results: only the directory "Linux-dir" should be regarded and filled
in directly since you use "cd" as command


Additional Information: It should be the same for mkdir, rmdir and possibly some
others

Comment 1 Hakon 2002-03-13 17:47:54 UTC
Not "mkdir" of course, taking back.

Comment 2 Bernhard Rosenkraenzer 2002-03-13 17:50:27 UTC
bash itself won't ever do this because it's expensive (parsing everything on tab).
It can be done using the bash-completions package from rawhide, though.


Note You need to log in before you can comment on or make changes to this bug.