Bug 610527 - SELinux is preventing /usr/sbin/semodule access to a leaked /tmp/tmpLOtwKc file descriptor.
SELinux is preventing /usr/sbin/semodule access to a leaked /tmp/tmpLOtwKc fi...
Status: CLOSED DUPLICATE of bug 610521
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:f5da7b3a407...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-02 05:47 EDT by Mads Kiilerich
Modified: 2011-02-03 16:46 EST (History)
344 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-02 05:53:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mads Kiilerich 2010-07-02 05:47:40 EDT
Summary:

SELinux is preventing /usr/sbin/semodule access to a leaked /tmp/tmpLOtwKc file
descriptor.

Detailed Description:

[semodule has a permissive type (semanage_t). This access was not denied.]

SELinux denied access requested by the semodule command. It looks like this is
either a leaked descriptor or semodule output was redirected to a file it is not
allowed to access. Leaks usually can be ignored since SELinux is just closing
the leak and reporting the error. The application does not use the descriptor,
so it will run properly. If this is a redirection, you will not get output in
the /tmp/tmpLOtwKc. You should generate a bugzilla on selinux-policy, and it
will get routed to the appropriate package. You can safely ignore this avc.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385)

Additional Information:

Source Context                system_u:system_r:semanage_t:s0-s0:c0.c1023
Target Context                system_u:object_r:initrc_tmp_t:s0
Target Objects                /tmp/tmpLOtwKc [ file ]
Source                        semodule
Source Path                   /usr/sbin/semodule
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           policycoreutils-2.0.82-31.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-28.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   leaks
Host Name                     (removed)
Platform                      Linux (removed) 2.6.33.5-124.fc13.i686.PAE #1 SMP Fri
                              Jun 11 09:42:24 UTC 2010 i686 i686
Alert Count                   3
First Seen                    Fri 02 Jul 2010 11:46:15 AM CEST
Last Seen                     Fri 02 Jul 2010 11:46:17 AM CEST
Local ID                      00f8c9ea-3c53-4948-8111-1a7d6339e02f
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1278063977.378:20525): avc:  denied  { append } for  pid=15879 comm="semodule" path="/tmp/tmpLOtwKc" dev=sda3 ino=83291 scontext=system_u:system_r:semanage_t:s0-s0:c0.c1023 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=file

node=(removed) type=AVC msg=audit(1278063977.378:20525): avc:  denied  { append } for  pid=15879 comm="semodule" path="/tmp/tmpLOtwKc" dev=sda3 ino=83291 scontext=system_u:system_r:semanage_t:s0-s0:c0.c1023 tcontext=system_u:object_r:initrc_tmp_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1278063977.378:20525): arch=40000003 syscall=11 success=yes exit=0 a0=938cd08 a1=938cd58 a2=9388bb8 a3=938cd58 items=0 ppid=15878 pid=15879 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="semodule" exe="/usr/sbin/semodule" subj=system_u:system_r:semanage_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  leaks,semodule,semanage_t,initrc_tmp_t,file,append
audit2allow suggests:

#============= semanage_t ==============
allow semanage_t initrc_tmp_t:file append;
Comment 1 Mads Kiilerich 2010-07-02 05:53:18 EDT
Bug 610521 happened at the same and references the same temp file but with a different tool, so I guess they have the same cause and are more or less duplicates.

*** This bug has been marked as a duplicate of bug 610521 ***
Comment 2 evarie 2010-07-12 12:42:47 EDT
For me it is signed with SELinux.
I have a picture of de problems url=http://www.evarie.dse.nl/fedora13/SELinux.Troubleshoot_error-log.jpg

In this picture, you can see that the error is coming
form a temporary file at /tmp/tmpqddjbt

And the error was came after my first fresh installed Fedora 13 on my Dell Optiplex GX260 with a internet connection.

The picture has the text:
SELinux blocked entry till a lekaged file write.

SELinux belet  /usr/sbin/semodule toegang tot een gelekte /tmp/tmpqddjbt bestands beschrijving. 

/sbin/setfiles/     /tmp/tmpqddjbt

/usr/sbin/tzdata-update    /tmp/tmpqddjbt

/usr/sbin/groupadd         /tmp/tmpqddjbt
Comment 3 Filip Hristov 2010-07-12 21:38:36 EDT
That went on during the update immediate after the installation.
My machine is Intel P45 with Nvidia PCI-E GC.
Comment 4 Filip Hristov 2010-07-12 22:17:25 EDT
That went on during the last update (from 08.july.2010) immediate after install
Fedora 13 on my computer - absolutely the same 4 bugs as these up of evarie.
My machine is Intel P45 with Nvidia PCI-E GC.
Comment 5 roberto_francescon 2010-07-25 16:34:16 EDT
I just turned on the computer, and logged in.
Comment 6 Jeff Lawlor 2010-08-10 09:30:25 EDT
Occurred when installing updates.
Comment 7 Lucas 2010-08-17 16:34:35 EDT
This occurred after I removed open office packages, performed a lengthy update and after I restarted my pc.

Note You need to log in before you can comment on or make changes to this bug.