Bug 61059 - Hampton Beta Install Hangs on "Loading aic7xxx"
Hampton Beta Install Hangs on "Loading aic7xxx"
Status: CLOSED WONTFIX
Product: Red Hat Public Beta
Classification: Retired
Component: kernel (Show other bugs)
fisher
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-12 16:22 EST by Richard Schaal
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-21 02:38:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Schaal 2002-03-12 16:22:42 EST
Description of Problem:
Installing Hampton Beta via network install hangs on message "loading aic7xxx"
for an extended period of time.  Finally, the installation says that it can't
find a disk to install on.  Had installed RedHat 7.2 two weeks earlier without
incident.  This also occurs after booting the CDROM directly.

Version-Release number of selected component (if applicable):
Hampton Beta


How Reproducible:
Every time.


Steps to Reproduce:
1. Boot CDROM 1
2. 
3. 

Actual Results:
Long delay after loading scsi driver and ultimately a claim that no installable
disk exists.


Expected Results:
Should have found SCSI disk 0, and proceeded with partitioning.


Additional Information:
System is a Intel ISP2150G - 2X Pentium!!! 850MHz
Comment 1 Arjan van de Ven 2002-03-12 16:31:30 EST
The intel ISP2150's have the 440GX chipset if I remember it right.
There is a known bios bug in this 440GX/ISP21xx series machine which gets the
IRQ routing ($PIR table) wrong. Instead of fixing this trivial bug, Intel has
decided to declare this machine unsupported by Linux.

In the past we had a (manually activatable) workaround for this bug; I will port
this to the hampton kernel in the next few weeks; I'm surprised someone from
Intel cares....it has been 10 months or so since we reported this bios bug.
Comment 2 Richard Schaal 2002-03-20 20:28:46 EST
Just for grins, I built the "off the shelf" linux-2.4.18 kernel and 
booted it without difficulty.  - Richard
Comment 3 Arjan van de Ven 2002-03-21 02:38:35 EST
Sure if you build a kernel with UP APIC enabled it'll work; same for a SMP kernel
Comment 4 Michael K. Johnson 2002-05-20 13:02:34 EDT
We've put the workaround in, but this is a bug in the Intel-provided BIOS
which we won't fix because we can't fix...
Comment 5 Richard Schaal 2002-05-20 18:14:27 EDT
I'm probably just obtuse, but just what _IS_ the work-around?  
Thanks.
Comment 6 Arjan van de Ven 2002-05-21 03:53:35 EDT
The workaround is to ignore the buggy $PIR table for this exact bios by adding
the DMI identifiers to the hall-of-shame.

Note You need to log in before you can comment on or make changes to this bug.