Bug 61065 - Compiled Perl @INC does not match current RPM line-up.
Compiled Perl @INC does not match current RPM line-up.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: xchat (Show other bugs)
7.2
All Linux
medium Severity low
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-12 17:27 EST by Francois Guimond
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-12 23:57:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Francois Guimond 2002-03-12 17:27:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
X-Chat saves the @INC (list of include dirs) in its compiled form.  The current
X-Chat RPM (xchat-1.8.7-1.72.0) was compiled against the Perl 5.6.0 RPMs which
are now 5.6.1 and therefore have different include dirs.  This means that Perl
scripts no longer run correctly in X-Chat, unless it is rebuilt from the SRPM.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install X-Chat and Perl from the current line up:
  - xchat-1.8.7-1.72.0
  - perl-5.6.1-26.72.3
2.Write a simple Perl script (such as one containing only the "use
  strict;" pragma).
3.Load the script in X-Chat
  (Scripts & Plugins -> Load -> Perl Script..).


Actual Results:  It displays an error saying it cannot find strict.pm in the
@INC list (which will be easily identified as the Perl 5.6.0 Perl @INC).


Expected Results:  It should load the file without problems (no error output).

Additional info:

This is not a bug in itself, but an error in the line-up of RPMs which makes
X-Chat lose it's important Perl scripting functionality. Simply rebuilding the
RPM from the SRPM solves the problem.
Comment 1 Mike A. Harris 2002-03-12 23:57:00 EST
This is unfortunate to have happened, but aparently any app using
an embedded perl interpreter will need to be rebuilt as well.  I've
got quite a full plate of higher priority items right now, so I
probably wont release updated packages right away.

Chip, in the mean time, if you plan on releasing an group erratum for
packages broken by the perl update, go ahead if you like. Might want
to bounce a message off internal lists to see if anyone can think of
other packages that might be affected.

If not, just hold off a month or so and I'll do an xchat enhancement
release, maybe sooner time permitting.  1.8.8 is out and in rawhide now.
Comment 2 Mike A. Harris 2002-05-20 23:33:42 EDT
I'm closing this as fixed in RHL 7.3, however there WILL be an official
update to xchat 1.8.9 coming out soon from us too.

Note You need to log in before you can comment on or make changes to this bug.