Bug 6107 - installer dies after an "exec:permission denied" message
installer dies after an "exec:permission denied" message
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-19 19:50 EDT by jlee4
Modified: 2015-01-07 18:38 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-10-20 00:13:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jlee4 1999-10-19 19:50:12 EDT
The installer dies, here's the sample output:

running install...
running /sbin/loader
/tmp/eepro100.o: a module eepro100 already exists
/tmp/raid0.o: a module raid0 already exists
exec:permission denied
install exited abnormally
sending termination signals
.
.
etc.

I am running this off a bootable cdrom that I made, but I
have also tried it off of a floppy drive.  I've also
downloaded the boot image from another mirror, did a "cmp"
on the two boot images, they're the same.  I've tried this
on two different computers, as well, and both gave me the
same problem.

I've tried this on an IBM Intellistation PII, as well as a
unmarked brand PIII, both giving the same problems, even
with different components.

Any workaround or fix for this problem would be greatly
appreciated.
Comment 1 Bill Nottingham 1999-10-19 22:42:59 EDT
What are the permissions like in RedHat/instimage on the CD-ROM?
Comment 2 jlee4 1999-10-20 00:03:59 EDT
the permissions for RedHat/instimage are: r-xr-xr-x, as are the
subdirectories of instimage.
Comment 3 jlee4 1999-10-20 00:06:59 EDT
Ok, I think the problem is the executables in instimage/usr/bin don't
have the execute permissions set for some of them, for whatever
reason.  That's not very friendly.

I assume this would definitely cause some problems, especially when
things like rpm and bash don't have execute permission.

Let me know if I'm wrong, but I think this one can be closed.
Comment 4 Bill Nottingham 1999-10-20 00:13:59 EDT
Yup, that's why it's dying.

Note You need to log in before you can comment on or make changes to this bug.