This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 61071 - kickstart xconfig options ignored with multiple video cards
kickstart xconfig options ignored with multiple video cards
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-12 18:41 EST by Crutcher Dunnavant
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-01 19:34:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Crutcher Dunnavant 2002-03-12 18:41:41 EST
Description of Problem:

I have a machine with an on-board video card, and a pci video card.
Anaconda autodetects the on-board, but the bios hints for the pci
card to be used, and Xconfigurator detects the pci card.

The fun part is that anaconda ignores the card settings for 'xconfig'
in my kickstart file, and uses the on-board card. And the kickstart
line I am using comes directly from anaconda-ks.cfg, after manually
telling anaconda the correct settings.

The line in question:

xconfig --card "NVIDIA Riva TNT2 (generic)" --videoram 16384 --hsync 30.0-85.0
--vsync 48.0-120.0 --resolution 1024x768 --depth 16
Comment 1 Jeremy Katz 2002-03-14 18:22:55 EST
Anaconda and especially kickstart doesn't always cope well on machines with
multiple video adaptors and we don't have any machines in the building which
exhibit the problem, but there are some GX110s at NCSU with onboard i810 video
and an add-on nvidia card that I'll try to get over to look at
Comment 2 Crutcher Dunnavant 2002-03-14 20:02:06 EST
Um, yep. They are in fact i810 onboard adapters. The systems are from Dell.
Sorry for leaving that bit out.

But, if it's given an _explicit_ switch, why should it even try probing?
Comment 3 Jeremy Katz 2002-03-14 20:24:28 EST
Because it still does some degree of probing to find out how much crack you're
on and to make sure it can start X, but it's supposed to ignore its probe
results.  There's some weirdness with doing multiple probes in there though
that's probably fubar'ing things.
Comment 4 Michael Fulbright 2002-04-11 21:48:41 EDT
Deferring to a future release.

Note You need to log in before you can comment on or make changes to this bug.