Bug 610733 - soap Transaction duration
Summary: soap Transaction duration
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: condor   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: 2.0
: ---
Assignee: Matthew Farrellee
QA Contact: MRG Quality Engineering
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-02 10:48 UTC by Lubos Trilety
Modified: 2011-01-31 21:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-31 21:57:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SchedLog (766 bytes, text/plain)
2010-07-02 10:48 UTC, Lubos Trilety
no flags Details

Description Lubos Trilety 2010-07-02 10:48:10 UTC
Created attachment 429009 [details]
SchedLog

Description of problem:
When some methods which require transaction identification is called using soap also parameter duration has to be filled.
Example:
<transaction>
  <id>766526725</id>
  <duration>120</duration>
</transaction>
Moreover this duration parameter is evaluated by condor, which means that it will be changed after calling such method.

Version-Release number of selected component (if applicable):
condor-7.4.4-0.4
python-suds-0.3.9-1 (used as soap client)

How reproducible:
100%

Steps to Reproduce:
1. run schedd with D_FULLDEBUG and soap enabled
2. start soap transaction, choose a long duration (e.g. 300)
3. run newCluster soap method, fill Nr. 1 as transaction duration value
  
Actual results:
transaction was aborted one second after newCluster request

Expected results:
The transaction duration was not changed and transaction goes on till 300s after calling of beginTransaction
The duration should not be mandatory attribute for methods which require transaction id

Additional info:
see Scheduler output in attachment

Comment 1 Matthew Farrellee 2010-07-06 15:20:38 UTC
BeginTransaction and ExtendTransaction were originally intended to be the only means to alter the duration of a transaction. The duration given by the client is a request and the returned duration is what the Schedd actually picked, e.g. ask for -10 second duration and the Schedd will probably give you a second.

The duration is supposedly optional in the schema, but is not in practice. Each call extends the transaction by the specified duration.

Recommendation here is to treat the Transaction returned as immutable. Modification of either the Id or the Duration enters undefined space.

Comment 2 Matthew Farrellee 2010-07-06 15:21:44 UTC
Paths for this BZ:
 o RFE for enforcement of immutability of Transaction
 o Close as WONTFIX, be warned if modifying the Transaction

Comment 3 Matthew Farrellee 2011-01-31 21:57:15 UTC
Of the two paths it is not worthwhile to enforce the immutability. Closing as WONTFIX.


Note You need to log in before you can comment on or make changes to this bug.