Bug 610757 - After refreshing traceback abrt still won't let me report it
After refreshing traceback abrt still won't let me report it
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: abrt (Show other bugs)
6.1
All Linux
medium Severity medium
: rc
: ---
Assigned To: Denys Vlasenko
Michal Nowak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-02 07:45 EDT by Michal Nowak
Modified: 2013-03-07 21:10 EST (History)
6 users (show)

See Also:
Fixed In Version: abrt-1.1.9-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 14:33:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
traceback abrt refused to send under 1.1.8 (127.46 KB, application/octet-stream)
2010-07-14 08:51 EDT, Scott Dodson
no flags Details

  None (edit)
Description Michal Nowak 2010-07-02 07:45:00 EDT
Description of problem:

I have crash in nm-connection-editor from NM-gnome, I tried to report it but abrt was not able to gather all -debuinfos and thus was not able to create usable traceback. I installed -debuginfos via `debugino-install` and then hit "Refresh" in the same abrt-gui instance. Traceback was recreated and looked pretty nice, however I still was not able to proceed in the wizard, abrt-gui still had text regardin unusability of the backtrace.

It seems abrt is not re-evaluating the traceback or that information did not get to abrt-gui.

Version-Release number of selected component (if applicable):

1.1.8-2.el6
Comment 1 RHEL Product and Program Management 2010-07-02 08:03:17 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 2 Scott Dodson 2010-07-06 10:41:50 EDT
This seems to happen for both kernel and userland crashes. For kernel crashes it doesn't look like the traceback has any additional information after installing the debuginfo packages, but for userland cores the traceback is definitely more complete after "debuginfo-install gnome-screensaver". However at the end of the traceback it does have the following :

End of assembler dump.
Debuginfo absent: 00741bc830167c952a6b96a13bdcc11c7d052bf7
Debuginfo absent: 0da50302f4e64efb1f6116e060dcdab1c065f6c4
Debuginfo absent: 1091613e71ba2afa6378d02d4bd8ec2a7f3ebb47
Debuginfo absent: 132e7471285c82aec37533f5123041ee67ce2e9a
Debuginfo absent: 15564ab5d1bbdbaeb1204ac1ccb107055eaba851
Debuginfo absent: 2ced44fc5b46ce6235b128b774e252f41f27373e
Debuginfo absent: 2eeb78d690d9cf0d9bcae44624c6894d2227d57f
Debuginfo absent: 335fae88fd8dd3f44e251f68ea0bb9af37671856
Debuginfo absent: 3673912935b1983c5d616e18b01d7552db5a0bc8
Debuginfo absent: 377e15d7559da4f2ee697c61b6e83ad20482a566
Debuginfo absent: 384f8199397d12195afe416eba62cd7e118cd1e0
Debuginfo absent: 388c66654b1593041e05cdd8e9aa606c8fcebd1d
Debuginfo absent: 3ac79b2b98b7665c7772ecb22f4959c4f104a6bc
Debuginfo absent: 3dc1f5c68ed7fb960fd84e20dfcdc85a95c3ebbf
Debuginfo absent: 4a36f8b932130acbe6e6a7372342b97a9d9a8b6b
Debuginfo absent: 529d16e4bb6170f1b5b1bfec2510f2404c84e510
Debuginfo absent: 666eb64674361e47044062c389dd068c6125fe96
Debuginfo absent: 6d385a4b80740901718b43368d1a1ce47ef672e8
Debuginfo absent: 6e7fe2b5cf16cacb1b035fa389fff8be1d164117
Debuginfo absent: 7c35453921058b29cf27cb05c7c0f0feb5833e87
Debuginfo absent: 80c30e8d48b7682e0e1c804185457b288213899a
Debuginfo absent: 87079f0796e44f96db4cd49e76e8664daf10480d
Debuginfo absent: 871f73c17faeb2c2113ea6d6a0e2980cfc14d367
Debuginfo absent: 9c481a2d4da3a93eba8c003ad7b5ee93561e6a97
Debuginfo absent: b3d2d172b9a201cae7af5250e6ae760c51251a51
Debuginfo absent: bd84511e579372eed296c422f4e1c67c578bd448
Debuginfo absent: c35e5c8f42786f04cc8615cdcaee954a5a46db1e
Debuginfo absent: c8d2b6ccd2627cd196e0c192c5026e91e856fa69
Debuginfo absent: c9441f0b9266efe7c925df31607ca47943a10893
Debuginfo absent: cdc5075b0a7acad6e8e1608100f85e89a1a78c95
Debuginfo absent: d0729f1c1d50e3d32275731a0350d8a3616ba6ae
Debuginfo absent: e4a9606ebe02883270a3e1933ae8f35cc1477027
Debuginfo absent: ee4daeec2db6f32df2b0afd7dda00f718d681dbe
Debuginfo absent: f73c70c08e8dfb779c49a1d27c677619e72d523e

It also has this at the beginning of the traceback :

warning: core file may not match specified executable file.
[New Thread 2802]
Core was generated by `gnome-screensaver'.
Comment 5 Denys Vlasenko 2010-07-14 06:19:31 EDT
Can you attach the actual backtrace which abrt still rates as "bad"?
Comment 6 Michal Nowak 2010-07-14 07:24:00 EDT
I don't have it.
Comment 7 Michal Nowak 2010-07-14 07:40:15 EDT
However, I just have found old crash w/o any traceback. abrt obviously said, I can't send, so I did refresh, I got at least some traceback

warning: core file may not match specified executable file.
[New Thread 1359609856]
warning: Selected architecture i386:x86-64 is not compatible with reported target architecture i386
warning: Architecture rejected target-supplied description
warning: Couldn't recognize general-purpose registers in core file.
Core was generated by `/usr/sbin/vsftpd /etc/vsftpd/vsftpd.conf'.
Program terminated with signal 2816, Unknown signal.
warning: Couldn't recognize general-purpose registers in core file.
#0  0x0000000000000000 in _start () from /lib64/ld-linux-x86-64.so.2

Thread 1 (Thread 1359609856):
Cannot access memory at address 0x0
From                To                  Syms Read   Shared Object Library
0x0000000000000000  0x0000000000017e44  Yes         /lib64/ld-linux-x86-64.so.2
No symbol "__abort_msg" in current context.
No symbol "__glib_assert_msg" in current context.
rax            0x0	0
rbx            0x0	0
rcx            0x0	0
rdx            0x0	0
rsi            0x0	0
rdi            0x0	0
rbp            0x0	0x0
rsp            0x0	0x0
r8             0x0	0
r9             0x0	0
r10            0x0	0
r11            0x0	0
r12            0x0	0
r13            0x0	0
r14            0x0	0
r15            0x0	0
rip            0x0	0
eflags         0x0	[ ]
cs             0x0	0
ss             0x0	0
ds             0x0	0
es             0x0	0
fs             0x0	0
gs             0x0	0
Dump of assembler code for function _start:
=> 0x0000000000000000 <+0>:	mov    %rsp,%rdi
   0x0000000000000003 <+3>:	callq  0x630 <_dl_start>
End of assembler dump.
Debuginfo absent: 2959a1c946561a9fc29971f78de51102c51a4ffb
Debuginfo absent: 2d53f0a6153cfdede656ad092be98d16bed54126
Debuginfo absent: 35cdc2b316e0ac45ffb03d92835f86b539121953
Debuginfo absent: 5ce7c1b2ec127e739556df5ce328bb51b2e190c6
Debuginfo absent: 5e03c8c6562397b8ea21558a1811edb6e0edc734
Debuginfo absent: 5f09abd22c7894dd1a59672354680e1774a3212f
Debuginfo absent: 67b0b667cb8b76e1822b54ee4dd9994f1730b45a
Debuginfo absent: 72f49e28b5a8349cf5a13ef14bef9bb2bdc93b62
Debuginfo absent: 88e5a1eb486226b54f1e2ef9fac66bc21960574d
Debuginfo absent: 8d9c93300cfd174946ed38496863a2605f8a4c2d
Debuginfo absent: 90219ddb2d727ed9b41b3d0f10785a800028ca1c
Debuginfo absent: 92f5b7bf70e804826dbaf98379e3476bbe1615ba
Debuginfo absent: a537c017ac2a3ffb9c51aed2374932d9751370c9
Debuginfo absent: ac8566a639373527cb4ba242fdd0ac88edc8b07c
Debuginfo absent: b51a325e1b65daf8630dcb6baadf877a31b07037
Debuginfo absent: c75e7456439d81d7197bd78505f6e28ee9faf7fa
Debuginfo absent: ceeae0b9fb3d603472e83d6deabbb5319d68c5e9


and abrt now let me go on... so it may be fixed in 1.1.9.

Other thing which came to my mind is that this backtrace seems to me totally useless -- but I may be wrong.
Comment 8 Scott Dodson 2010-07-14 08:51:01 EDT
Created attachment 431756 [details]
traceback abrt refused to send under 1.1.8

Attached is a traceback that abrt refused to send prior to upgrading to 1.1.9. 

This problem definitely doesn't happen in 1.1.9, but I imagine it's because the ratings were disabled per this changelog entry :

- GUI: allow sending crashes without rating (jmoskovc@redhat.com)
Comment 9 Michal Nowak 2010-07-15 04:34:25 EDT
(In reply to comment #8)
> - GUI: allow sending crashes without rating (jmoskovc@redhat.com)    

I see... that's why I had hard time finding "bad" backtrace
Comment 10 Karel Klíč 2010-07-15 04:52:19 EDT
Scott, Michal,

no, the ratings were not disabled. That changelog entry says that the crashes where the rating is not present because it does not make sense (e.g. kernel oops) are not blocked by the GUI (that was a bug). It isn't that the crashes with poor backtraces are not blocked -- those still get low rating and they are not allowed to be sent.
Comment 13 releng-rhel@redhat.com 2010-11-10 14:33:25 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.