Bug 61076 - up2date does not forward through ssh -X
Summary: up2date does not forward through ssh -X
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: usermode (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-13 05:06 UTC by Need Real Name
Modified: 2015-01-07 23:55 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-07 12:14:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-03-13 05:06:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461)

Description of problem:
up2date does not work through an ssh connection with X forwarding on. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start a remote Xserver.  (Used CYGWIN/Xfree86 on windows machine)
2. Connect to linux server using ssh -X user@somelinuxhost.com
3. start up2date 
	

Actual Results:  You see the up2date root logon message through X, then 
up2date hangs.   

Expected Results:  up2date should have opened in X. 

Additional info:

up2date works fine if it is run via a telnet session setting a 
DISPLAY=remoteXserver:0.0; 
export DISPLAY

Also this worked prior to the 2.7.11 release.

Comment 1 Adrian Likins 2002-03-18 22:04:16 UTC
This seems to work fine for me. I need more info.

after ssh'ing, whats the value of $PATH and $DISPLAY?

what happens if you su to root and run "up2date"? 
what happens if you su to root and run "/usr/sbin/up2date"?

Comment 2 Need Real Name 2002-03-19 06:36:50 UTC
After ssh is connected; 
DISPLAY=localhost:10.0
PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/X11R6/bi
n:/root/bin:/root/bin
When you su to root it just hangs.  Obviously you don't see the X window 
requesting root logon.  

I tried a different connection method,using Tera Term Pro with the SSH plugin 
and WinAxe 6.2 as the Xserver. When I run up2date using this method I get a X 
fowarding error. 

 TTSSH 'Remote X application sent incorrect authentication data. Its X session 
is being cancelled.'




Comment 3 Adrian Likins 2002-05-08 21:05:20 UTC
reassinging to usermode, since that seems to be causing the problems

Comment 4 Jindrich Novy 2005-04-07 12:14:18 UTC
Nope, this looks like the ssh X forwarding problem, usermode is not likely to be
a culprit here.

Closing this for now. Please file a new bug against some recent release if the
problem persists.


Note You need to log in before you can comment on or make changes to this bug.