This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 61077 - Konsole doesn't support 'cbt' terminfo capability in 'xterm'
Konsole doesn't support 'cbt' terminfo capability in 'xterm'
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ncurses (Show other bugs)
7.2
All Linux
medium Severity low
: ---
: ---
Assigned To: wdovlrrw
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-13 00:15 EST by Nathan Bryant
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-13 00:15:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nathan Bryant 2002-03-13 00:15:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020311

Description of problem:
The KDE terminal emulator, Konsole, doesn't support the 'cbt' capability
(back_tab) - this leads to cursor positioning bugs in various ncurses-based
programs, and also phantom characters that weren't erased properly by the
backspace. For example, I'm unable to meaningfully edit text in the current CVS
'citadel' client (http://uncensored.citadel.org/) because the cursor skips too
far to the left or right and I'll end up backspacing over too much text. This
also affects irssi.

The problem is that Red Hat 7 uses a fairly complete/recent terminfo description
as the *default* for xterm - for this purpose, I'm not sure if I agree with
using capabilities more recent than what is in the 'xterm-color' description,
for compatibility with people who might remotely log in from older terminals.

At any rate, the fix is to remove the 'cbt' capability from 'xterm' or to map
'xterm' to something like 'xterm-color' that doesn't use this capability. IMO it
would be good to just remove 'cbt' from most descriptions since it's not
necessary and is likely to cause problems


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run irssi in Konsole, type several words and then backspace over them
2.or run latest CVS 'citadel' client in Konsole (http://uncensored.citadel.org/)
3.
	

Actual Results:  phantom characters, badly positioned cursor, unable to edit
meaningfully

Expected Results:  none of the above

Additional info:
Comment 1 Bernhard Rosenkraenzer 2002-04-08 10:08:40 EDT
Agreed, done in -26

Note You need to log in before you can comment on or make changes to this bug.