Bug 610802 - SELinux is preventing /usr/sbin/automount "read" access on auto.master.
SELinux is preventing /usr/sbin/automount "read" access on auto.master.
Status: CLOSED DUPLICATE of bug 609235
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
12
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:52512a78e31...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-02 09:30 EDT by Frank Murphy
Modified: 2010-07-07 07:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-07 07:01:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Murphy 2010-07-02 09:30:24 EDT
Summary:

SELinux is preventing /usr/sbin/automount "read" access on auto.master.

Detailed Description:

SELinux denied access requested by automount. It is not expected that this
access is required by automount and this access may signal an intrusion attempt.
It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:system_r:automount_t:s0
Target Context                unconfined_u:object_r:tmp_t:s0
Target Objects                auto.master [ file ]
Source                        automount
Source Path                   /usr/sbin/automount
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           autofs-5.0.5-23.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-41.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.31.5-127.fc12.i686 #1 SMP Sat Nov 7 21:41:45
                              EST 2009 i686 i686
Alert Count                   2
First Seen                    Fri 02 Jul 2010 13:06:12 IST
Last Seen                     Fri 02 Jul 2010 13:17:44 IST
Local ID                      ca34e2ea-9832-4996-bd22-3afed3ba8689
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1278073064.284:23926): avc:  denied  { read } for  pid=2378 comm="automount" name="auto.master" dev=dm-6 ino=79373 scontext=unconfined_u:system_r:automount_t:s0 tcontext=unconfined_u:object_r:tmp_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1278073064.284:23926): arch=40000003 syscall=33 success=no exit=-13 a0=b7678838 a1=4 a2=146818 a3=b76784c8 items=0 ppid=2376 pid=2378 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=1 comm="automount" exe="/usr/sbin/automount" subj=unconfined_u:system_r:automount_t:s0 key=(null)



Hash String generated from  selinux-policy-3.6.32-41.fc12,catchall,automount,automount_t,tmp_t,file,read
audit2allow suggests:

#============= automount_t ==============
allow automount_t tmp_t:file read;
Comment 1 Frank Murphy 2010-07-02 09:32:23 EDT
This is an F12 Guest trying to mount a localrepo using autofs
Comment 2 Miroslav Grepl 2010-07-07 07:01:18 EDT

*** This bug has been marked as a duplicate of bug 609235 ***

Note You need to log in before you can comment on or make changes to this bug.