Bug 610832 - Evolution crashes when contacting MAPI server
Summary: Evolution crashes when contacting MAPI server
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: evolution-mapi
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Matthew Barnes
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-02 14:28 UTC by Göran Uddeborg
Modified: 2010-11-10 20:22 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-11-10 20:22:42 UTC


Attachments (Terms of Use)
Stack trace from the crash (5.66 KB, text/plain)
2010-07-02 14:28 UTC, Göran Uddeborg
no flags Details

Description Göran Uddeborg 2010-07-02 14:28:59 UTC
Created attachment 429065 [details]
Stack trace from the crash

Description of problem:
I'm trying to have evolution contact an Exchange 5.5 server using MAPI, in order to manage my meeting invitations.  However, after having configured server and user name and when pressing "Authenticate", evolution crashes.

Version-Release number of selected component (if applicable):
Many could be involved, but these are the more obviously relevant ones:
evolution-mapi-0.28.2-1.el6.x86_64
evolution-data-server-2.28.2-3.el6.x86_64
evolution-2.28.2-3.el6.x86_64


How reproducible:
Every time

Steps to Reproduce:
1. Configure an MAPI account in evolution
2. Click "authenticate"
  
Actual results:
Crash

Additional info:
I enclose the backtrace.  The output on the console after clicking is

Create profile with goran.uddeborg corp entframail1.corp.gds.jeppesen.com
libexchangemapi-Message: exchange-mapi-connection.c:3029: exchange_mapi_create_profile: lock(connect_lock)
Logging into the server... Abort (core dumped)

Comment 7 Göran Uddeborg 2010-08-06 14:44:23 UTC
I upgraded to "beta 2 refresh", and the behaviour has changed.  Now I can authenticate, and some of my appointments are shown.  Not all, and if I try to add a new everything hangs.  So it's not quite working yet, but I can't reproduce this particular problem any more.

Comment 8 Vladimir Benes 2010-08-18 09:30:52 UTC
Göran,
could you please open a new bug for what you are seeing so we can close this authentication crasher and continue solving the UI freeze?

thanks,
Vladimir

Comment 9 Göran Uddeborg 2010-08-18 09:57:32 UTC
I actually did that after writing comment 7, but forgot to add another comment here.

Bug 621941 and bug 621943 describe the problems I see with the latest beta.

Comment 10 Vladimir Benes 2010-08-18 10:38:57 UTC
according to comment 5 and comment 7 this fix was verified
-> VERIFIED

Comment 11 releng-rhel@redhat.com 2010-11-10 20:22:42 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.